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Requirements Definition

• “Author Requirements in Simulink” on page 1-2
• “Import Requirements from Third-Party Tools” on page 1-5
• “Define Requirements Hierarchy” on page 1-8
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Author Requirements in Simulink
In Simulink® Requirements™, you organize your requirements in groups called
requirements sets. In each requirements set, you can create additional levels of hierarchy
for when you need more requirements to describe the details of a requirement.

In this tutorial, you use the Requirements Editor to create a requirements set to organize
related requirements and add requirements to the set.

Suppose that you are writing requirements for a controller model of an automobile cruise
control system. You develop these requirements, using your company’s numbering
standard for requirements (R1, R2, and so on).
ID and Description Rationale
R1: The maximum input throttle is 100% The maximum value of the throttle from

the acceleration pedal can be no greater
than 100%.

R2: Cruise control has a speed operation
range

Cruise control has a minimum and
maximum operating speed.

R2.1: The vehicle speed must be at least 40
km/h

The speed of the vehicle must be at least 40
km/h for the cruise control system to
engage.

R2.2: The vehicle speed cannot be greater
than 100 km/h

The maximum operational speed of the
cruise control system for the vehicle is 100
km/h.

Add these requirements to a model called crs_controller.

1 The model and supporting files are in a Simulink project. Open the project. At the
MATLAB® command prompt, enter:

slreqCCProjectStart
2 Open the model. At the command prompt, enter:

open_system('models/crs_controller')
3 Open the Requirements Editor. In the Simulink Editor, select Analysis >

Requirements > Requirements Editor.

The Requirements Editor opens with the requirements in view in the requirements
browser, arranged by requirements set. The crs_controller model has two
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requirements sets that you can see in the browser: crs_req_func_spec and
crs_req.

4 Add a requirements set in the requirements browser. From the Requirements Editor

toolbar, click New Requirement Set .
5 You save requirements sets to external files. Save your requirements set to a

writeable location and name it cruise_control_reqset.slreqx.
6 When you save requirements sets to external files, you can share requirements with

other models.
7 Add a requirement to your requirements set. Select the requirements set and click

Add Requirement .
8 In the Properties pane, enter details for the requirement. You can copy and paste

or drag requirements from another source to the Properties pane.

• Custom ID: R1
• Summary: Max input throttle %
• Description: The maximum input throttle is 100%.

If you do not specify a custom ID, the Requirements Editor numbers requirements in
order. Custom IDs let you use your company standards for labeling requirements
and set the numeric order. (Custom IDs cannot contain a # character.) You can also
use an ID to help locate a requirement by searching. Keywords also aid in searching
for a requirement.

9 Create the requirement R2. Right-click R1 and select Add Requirement After.
Enter details for the requirement:

• Custom ID: R2
• Summary: Cruise control speed operation range
• Description: Cruise control has a minimum and maximum operating speed.

10 Create the child requirement of R2. Right-click R2 and select Add Child
Requirement. Enter details for the requirement:
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• Custom ID: R2.1
• Summary: Maximum vehicle speed
• Description: The speed of the vehicle must be at least 40 km/h for the cruise

control system to engage.

Add the other child to requirement R2 if you want.

Tip You can rearrange the hierarchy by using the  or by dragging requirements.
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Import Requirements from Third-Party Tools
Using the Requirements Editor in Simulink Requirements, you can work with
requirements from third-party applications such as Microsoft® Word and Microsoft
Excel®.

You can choose to import external requirements content into Simulink or to create read-
only references to external requirements content in Simulink.

Importing external requirements into Simulink means that you can edit your
requirements directly from within Simulink. If you are performing all requirements-
based activity from within Simulink, choose this option. Requirements that you have

imported into Simulink appear with a  icon in the Requirements Editor.

You can choose to import requirements as read-only references. This option ensures that
your imported requirements retain their dependencies to the original requirements
document. Edit the original requirements document and click Update in the Properties
pane of the Requirements Editor to change your imported requirements. Requirements

that are referenced from external documents appear with a  icon in the Requirements
Editor.

Before starting the import process,

1 Open the Microsoft Word or Microsoft Excel document.
2 Open the Requirements Editor. by selecting Analysis > Requirements >

Requirements Editor from the Simulink menu.
3 Open the Document Import Wizard. In the Requirements Editor, select File >

Import. Select the document type in the Source pane. The document location is
populated automatically.

Note If you have more than one document open, the most recently opened document
is selected for import.

Import Options for Microsoft Word Documents

You can import requirements in plain and rich text formats from Microsoft Word
documents. Use the rich text format to import requirements content such as graphics,
tables, and other rich formatting.
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By default, imported requirements content matches the Microsoft Word document outline
of section headings. You can also import selectively requirements by using the following
qualifiers from the Requirement Identification menu:

• Predefined bookmarks in Microsoft Word to identify items and to serve as custom IDs.
• Regular expression search patterns to identify items by occurrence. For more

information on regular expression search patterns, see “Regular Expressions”
(MATLAB).

• You can also choose to ignore outline numbers in the section headers of your Microsoft
Word document.

Import Options for Microsoft Excel Spreadsheets

You can import requirements in plain and rich text formats from Microsoft Excel
spreadsheets. The plain text format imports only text and associates each column of your
spreadsheet to a requirement property. The rich text format imports graphics, layouts,
and captures multicell ranges.

Use the qualifiers from the Requirement Identification menu to select a subset of
your spreadsheet to import requirements from:

1 Choose individual rows and columns by mapping columns to requirement attributes.
Select Specify rows and columns and click Configure columns. If there are no
predefined headers in your spreadsheet, Simulink Requirements prompts you to
specify the row that contains headers for attribute names.

2 Select the range of rows and columns to import from the Configure columns dialog
box. Select how each column in your spreadsheet can be mapped to Properties and
Custom Attributes by choosing an option from the drop-down list. Consider the
following when you map columns to Properties and Custom Attributes:

• • You can select only one column each for the Custom ID and Summary.
• You can select one or more continuous columns for the Description and the

Rationale. The contents of these columns are concatenated into one field after
the import is completed.

• You must select at least one column for the Summary or the Description.

Skip columns from being imported by selecting the Ignore option.
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3 You can use regular expression search patterns to identify items by occurrence. For
more information on regular expression search patterns, see “Regular Expressions”
(MATLAB).
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Define Requirements Hierarchy
Using Simulink Requirements, you can derive lower-level requirements from higher-level
requirements to establish and manage parent-child relationships.

The requirement set is the top level of hierarchy for all requirements. All requirements
in Simulink Requirements are contained in requirement sets. Every top-level parent
requirement in a requirement set is the first-level hierarchy for that set.

Within a requirement set, you can change the level of individual requirements by using

the  icons in the Requirements Editor or on the Requirements Browser
toolbar. When you promote or demote a requirement with children, the parent-child
hierarchical relationship is preserved.

The Implementation and Verification Status metrics for a requirement set are
cumulatively aggregated over all the requirements in the set. Each parent requirement
in a requirement set derives its metrics from all its child requirements. For more
information on the Implementation and Verification Status metrics, see “Review
Requirement Implementation Status Metrics Data” on page 3-2 and “Review
Requirement Verification Status Metrics Data” on page 3-3.

Requirement Sets

You can create requirement sets from the Requirements Editor and from the
Requirements Browser. Requirement set files (.slreqx) are not inherently associated
with your Simulink models.

Requirement sets have built-in properties such as the Filepath and the Revision number
associated with them as metadata. Except for the description, properties of the
requirement set are read-only and are updated as you work with the requirement set.

Custom Attributes of Requirement Sets

You can define custom attributes for your requirement sets that apply to the
requirements they contain. Custom attributes extend the set of properties associated
with your requirements Custom attributes for a requirement set can be defined from the
Custom Attribute Registries pane of the Requirements Editor.

To define custom attributes for your requirement sets:
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1 Open the Requirements Editor. In the Simulink Editor, select Analysis >
Requirements > Requirements Editor.

2 Select the requirement set and click Add in the Custom Attribute Registries
pane.

3 The Custom Attribute Registration dialog opens. Select the type of custom attribute
you want to set for your requirements by using the Type drop-down list. You can
specify custom attributes as text fields, check boxes, and combo boxes. You cannot
change the properties of the custom attribute after you create it.

To view the custom attributes for your requirements in the spreadsheet, right-click the
requirement set and click Select Columns.

When you define a custom attribute as a combobox, the first entry is preset to Unset and
it cannot be renamed or deleted. Custom attributes that are imported as referenced
requirements from an external document become read-only custom attributes after they
are imported. The custom attributes of a requirment set are associated with every
individual requirement in the set and removing the custom attributes for a requirement
set removes it from all the requirements in the set.

 Define Requirements Hierarchy

1-9





Requirements Traceability and
Consistency

• “Link Blocks and Requirements” on page 2-2
• “Requirement Links” on page 2-5
• “Requirements Consistency Checks” on page 2-8
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Link Blocks and Requirements
You can create links between your requirements and the Simulink blocks or Stateflow®
objects that implement them. By linking between the model elements that implement
requirements, you can track whether all your requirements have been implemented. You
can also keep requirements and implementation in sync, for example, if a requirement
changed or if the implementation causes you to revise your requirements.

In this tutorial, you use the Requirements Perspective to work with your requirements in
the cruise control model. As in the Requirements Editor, you can add requirements sets
and requirements in the Requirements Perspective. In both views, you can link
requirements with blocks. In the Requirements Perspective, visual elements help you to
see the links between requirements and blocks.

1 In the crs_controller model, to preview the perspectives associated with the
model, click the perspectives control in the lower-right corner.

2 To open the Requirements Perspective, click the Requirements image.

The Requirements Perspective includes the Requirements Browser, docked at the
bottom of the Simulink editor. When you select a requirement, the Property
Inspector displays the Simulink Requirements Properties pane.

3 Link a requirement to the model element that implements it. Search for the
requirement that you want to link from. In the Requirements Browser search box,
enter Enable Switch Detection. As you type, matches are highlighted.
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4 To create a link, select the matching requirement and drag it onto the enbl inport
block. A badge appears on the block to show that a link was created. You see badges
only in the Requirements Perspective.

5 To see more information about the requirement, click the badge and select Show.

Clicking Show displays a requirement annotation on the model canvas. The
annotation displays the ID, the summary, and the relationship between the block
and the requirement. In this example, the block implements the requirement. For
other possible relationships, see “Requirement Links” on page 2-5.

• To see the requirement description, double-click the annotation.
• To edit the requirement, right-click the annotation and select Select in

browser. The requirement properties appear in the Property Inspector, where
you can edit them.

6 Exit the Requirements Perspective. Click the perspectives control and click the
requirements image.
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Requirement Links
Create links between your requirements and various Simulink model elements including
blocks, Stateflow objects, Simulink Test™ test objects such as test cases and test suites,
Simulink data dictionary entries, MATLAB code, and other requirements by using the
linking capabilities available in Simulink Requirements to keep track of how your
requirements relate to your model design.

You can create links to blocks and Stateflow objects directly from the Simulink Editor as
you work on your model by dragging requirements from the Requirements Browser in
the Requirements Perspective View. You can create links to Simulink Test test objects
from the Simulink Test Test Manager or from the Requirements Editor. For more
information on linking Simulink model elements to requirements, see “Link Blocks and
Requirements” and “Link to Test Cases from Requirements”.

Link Types

To keep track of how the various elements in your design are associated with your
requirements, you can specify the link type for your requirement links. Link types also
specify the nature of requirement-to-requirement links, such as where a requirement is
derived from a higher-level requirement.

Simulink Requirements provides these link types.
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Link Types in Simulink Requirements

Type Description
Related to General relationship between requirement

and model element. This link is
bidirectional.

Implemented by The model element implements the
requirement and vice versa. These link
types contribute to the Implementation
Status metric.

Implements

Verified by The verification model element or test case
verifies that the requirement is satisfied
and vice versa. These link types contribute
to the Verification Status metric.

Verifies

Derived from The destination is derived from the source
and vice versa.Derives

Refines The destination adds additional detail for
the functionality specified by the source
and vice versa.Refined by

Links between requirements and your Simulink model elements have a source and a
destination. Most of the link types are defined relative to the link direction. The Related
to link type denotes a general relationship between two entities.

The Implements/Implemented by and Verifies/Verified by link types communicate
requirement-model relationships. You must specify the source and the destination
correctly for requirements with these link types because the Implementation Status and
Verification Status rollup metrics are derived from these link types. For more
information on the Implementation Status and Verification Status rollup metrics see
“Review Requirement Implementation Status Metrics Data” on page 3-2 and “Review
Requirement Verification Status Metrics Data” on page 3-3.

Review Requirement Links

Review your requirement links from the Links View. The Links View is available in the
Requirements Editor and the Requirements Browser in the Requirements Perspective
view. Toggle between the Requirements and Links Views by using the View drop-down
list in the toolbar. When working in the Simulink Editor, you can review requirement
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links for individual requirements by using the Property Inspector in the Requirements
Perspective view. The Links View of the Requirements Browser in the Requirements
Perspective view displays only the outgoing links from your source artifacts. Other links
associated with your requirements are available in the Links pane in the Requirements
View. All the outgoing links from a source artifact are stored in a Link Set file (.slmx).

In the Links View, unresolved links are denoted by a  icon.
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Requirements Consistency Checks

Check Requirements Consistency in Model Advisor
• “Identify requirement links with missing documents” on page 2-8
• “Identify requirement links that specify invalid locations within documents”

on page 2-9
• “Identify selection-based links having descriptions that do not match their

requirements document text” on page 2-10
• “Identify requirement links with path type inconsistent with preferences”

on page 2-11
• “Identify IBM Rational DOORS objects linked from Simulink that do not link to

Simulink” on page 2-12

You can check requirements consistency using the Model Advisor.

Identify requirement links with missing documents

Check ID: mathworks.req.Documents

Verify that requirements link to existing documents.
Description

You used the Requirements Management Interface (RMI) to associate a design
requirements document with a part of your model design and the interface cannot find
the specified document.

Available with Simulink Requirements.
Results and Recommended Actions
Condition Recommended Action
The requirements document associated
with a part of your model design is not
accessible at the specified location.

Open the Requirements dialog box and fix
the path name of the requirements
document or move the document to the
specified location.

Capabilities and Limitations

You can exclude blocks and charts from this check.
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Tips

If your model has links to a DOORS® requirements document, to run this check, the
DOORS software must be open and you must be logged in.

See Also

“Maintenance of Requirements Links”

Identify requirement links that specify invalid locations within documents

Check ID: mathworks.req.Identifiers

Verify that requirements link to valid locations (e.g., bookmarks, line numbers, anchors)
within documents.

Description

You used the Requirements Management Interface (RMI) to associate a location in a
design requirements document (a bookmark, line number, or anchor) with a part of your
model design and the interface cannot find the specified location in the specified
document.

Available with Simulink Requirements.

Results and Recommended Actions
Condition Recommended Action
The location in the requirements document
associated with a part of your model design
is not accessible.

Open the Requirements dialog box and fix
the location reference within the
requirements document.

Capabilities and Limitations

You can exclude blocks and charts from this check.

Tips

If your model has links to a DOORS requirements document, to run this check, the
DOORS software must be open and you must be logged in.

If your model has links to a Microsoft Word or Microsoft Excel document, to run this
check, those applications must be closed on your computer.
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See Also

“Maintenance of Requirements Links”

Identify selection-based links having descriptions that do not match their requirements
document text

Check ID: mathworks.req.Labels

Verify that descriptions of selection-based links use the same text found in their
requirements documents.

Description

You used selection-based linking of the Requirements Management Interface (RMI) to
label requirements in the model's Requirements menu with text that appears in the
corresponding requirements document. This check helps you manage traceability by
identifying requirement descriptions in the menu that are not synchronized with text in
the documents.

Available with Simulink Requirements.

Results and Recommended Actions
Condition Recommended Action
Selection-based links have descriptions
that differ from their corresponding
selections in the requirements documents.

If the difference reflects a change in the
requirements document, click Update in
the Model Advisor results to replace the
current description in the selection-based
link with the text from the requirements
document (the external description).
Alternatively, you can right-click the object
in the model window, select Edit/Add
Links from the Requirements menu, and
use the Requirements dialog box that
appears to synchronize the text.

Capabilities and Limitations

You can exclude blocks and charts from this check.
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Tips

If your model has links to a DOORS requirements document, to run this check, the
DOORS software must be open and you must be logged in.

If your model has links to a Microsoft Word or Microsoft Excel document, to run this
check, those applications must be closed on your computer.

See Also

“Maintenance of Requirements Links”

Identify requirement links with path type inconsistent with preferences

Check ID: mathworks.req.Paths

Check that requirement paths are of the type selected in the preferences.

Description

You are using the Requirements Management Interface (RMI) and the paths specifying
the location of your requirements documents differ from the file reference type set as
your preference.

Available with Simulink Requirements.

Results and Recommended Actions
Condition Recommended Action
The paths indicating the location of
requirements documents use a file
reference type that differs from the
preference specified in the Requirements
Settings dialog box, on the Selection
Linking tab.

Change the preferred document file reference
type or the specified paths by doing one of the
following:

• Click Fix to change the current path to the
valid path.

• In the model window, select Analysis >
Requirements > Settings, select the
Selection Linking tab, and change the
value for the Document file reference
option.
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Linux Check for Absolute Paths

On Linux® systems, this check is named Identify requirement links with absolute
path type. The check reports warnings for requirements links that use an absolute path.

The recommended action is:

1 Right-click the model object and select Requirements > Edit/Add Links.
2 Modify the path in the Document field to use a path relative to the current working

folder or the model location.

Capabilities and Limitations

You can exclude blocks and charts from this check.
See Also

“Maintenance of Requirements Links”

Identify IBM Rational DOORS objects linked from Simulink that do not link to Simulink

Identify IBM® Rational® DOORS objects that are targets of Simulink-to-DOORS
requirements traceability links, but that have no corresponding DOORS-to-Simulink
requirements traceability links.
Description

You have Simulink-to-DOORS links that do not have a corresponding link from DOORS
to Simulink. You must be logged in to the IBM Rational DOORS Client to run this check.

Available with Simulink Requirements.
Results and Recommended Actions

The Requirements Management Interface (RMI) examines Simulink-to-DOORS links to
determine the presence of a corresponding return link. The RMI lists DOORS objects
that do not have a return link to a Simulink object. For such objects, create
corresponding DOORS-to-Simulink links:

1 Click the FixAll hyperlink in the RMI report to insert required links into the
DOORS client for the list of missing requirements links. You can also create
individual links by navigating to each DOORS item and creating a link to the
Simulink object.
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2 Re-run the link check.
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Requirements-Based Verification

• “Review Requirement Implementation Status Metrics Data” on page 3-2
• “Review Requirement Verification Status Metrics Data” on page 3-3
• “Justify Requirements” on page 3-5
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Review Requirement Implementation Status Metrics Data
Simulink Requirements provides you with Implementation Status rollups for your
requirement sets. You can use these status rollups to identify gaps in requirement
implementation in your design. Requirements that have the link type set to
Implemented by contribute to the Implementation Status rollup metric.

The Implementation Status metrics for a requirement set are cumulatively aggregated
over all the requirements in the set. Each child requirement belonging to a parent
requirement must be implemented for the parent requirement to be considered as
implemented.

You can view the Implementation Status metric for your requirement sets from both the
Requirements Editor and the Requirements Browser in the Requirements Perspective
View. To toggle the metric display, select Display > Implementation Status from the
Requirements Editor menu. You can update the Implementation Status metric for all the

requirement sets you have loaded in the Requirements Editor by clicking the  icon in
the toolbar. Hover your mouse over the Implemented column in the Requirements Editor
or Requirements Browser for each requirement or requirement set to view the
Implementation Status metric associated with it.
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Review Requirement Verification Status Metrics Data
Simulink Requirements maintains Verification Status rollups for your requirement sets.
You can use this status rollup to identify missing or incomplete requirement verification.
Verification status metrics are available if you have Simulink Design Verifier™ and use
Proof Objective blocks as requirement link destinations, or Simulink Test and use test
cases in the Test Manager as requirement link destinations.

A requirement must satisfy the following conditions to achieve full Verification status:

• The requirement has one or more links where the link type is set to Verified by.
• The link destinations for the Verified links must be either:

• Simulink Test test cases and test suites
• Simulink Design Verifier Proof Objective blocks
• Blocks from the Simulink Model Verification Library

• The verification associated with the link destination must pass. Every child
requirement belonging to a parent requirement must be verified for the parent
requirement to be considered verified.

A link to a verification item can have five possible Verification Statuses:

• Passed: The test linked with the requirement has passed.
• Failed: The test linked with the requirement has failed.
• Stale: The test result is out of date with respect to the test source.
• Unknown: The test result is unknown.
• No Result: The test linked with the requirement has no result.

You can view the Verification Status metric for your requirement sets from both the
Requirements Editor and the Requirements Browser in the Requirements Perspective
View. To toggle the metric display, select Display > Verification Status from the
Requirements Editor menu. You can update the Verification Status metric for all the

requirement sets you have loaded in the Requirements Editor by clicking the  icon in
the toolbar. Hover your mouse over the Verified column in the Requirements Editor or
Requirements Browser for each requirement or requirement set to view the
Verification Status metric associated with it.
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Justify Requirements
Use requirement justification to exclude requirements from the Implementation and
Verification Status metrics calculation for your requirement sets. You may have non-
functional requirements in your model design specification that cannot be implemented
in your design. You may also have requirements that require manual testing, instead of
linking to test cases or verification subsystems. You can justify these requirements to
override their Implementation and Verification statuses and iterate more effectively on
your model design.

A justification is an object associated with a requirement. All justification objects in a
requirement set are grouped under a single top-level justification object as its children.
Any requirement can be justified for implementation, verification, or both. Justified
requirements do not contribute to the overall aggregation of Implementation and
Verification Status metrics and appear light blue in the Implemented and Verified
columns of the Requirements Editor.

There are two workflows for justifying requirements in Simulink Requirements. You can
either create a new justification object and link requirements to it or use an existing
justification object and link requirements to it.

1
Create a justification object by clicking the  icon in the Requirements Editor or
Requirements Browser toolbar.

2 Right-click the requirement you want to link with the justification object and select
Justification > Create new for Implementation or Create new for
Verification.
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To justify a parent requirement and all its child requirements, select the Hierarchical
Justification option in the Property Inspector.
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Change Tracking and Team-Based
Workflows

• “Manage Requirements Across a Team” on page 4-2
• “Track Changes to Requirements Links” on page 4-5
• “Compare Requirements Sets” on page 4-10
• “Report Requirements Information” on page 4-12
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Manage Requirements Across a Team
With Simulink Requirements, you can use requirements in conjunction with Simulink
projects for team-based collaboration. You can create a repository of models, supporting
files, documents, requirements, and links by using Simulink projects. You can reuse
requirements and links sets for multiple projects. You can integrate shared library
models and requirements sets with local models and requirements sets.

The Role of Projects in Team-Based Workflows

After you “Author Requirements in Simulink” on page 1-2 and create links between
design elements and your requirements, you can use Simulink projects to share
requirements sets, requirements links, and Simulink models and supporting files across
your team.
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Your Simulink project can contain:

• Local, modifiable versions of models, requirements sets, requirements links, and
supporting files

• Shared library versions of models, requirements sets, requirements links, and
supporting files

If you incorporate the shared library models, requirements sets, requirements links, and
supporting files in your requirements analysis, you can create requirements links
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between your local models and shared requirements. You can also create requirements
between your local requirements and shared models and supporting files.

When you include local and shared library versions of models, requirements sets,
requirements links, and supporting files in your Simulink project, Simulink
Requirements loads all of the requirements sets and requirements links information for
the project when you open the project. Your shared library requirements data is
integrated into your local requirements data.
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Track Changes to Requirements Links
After you “Author Requirements in Simulink” on page 1-2 and create links between
design elements and your requirements, Simulink Requirements tracks the requirements
links and detects when links or requirements change. In the Requirements Editor,
changes to requirements links are highlighted in red. You can then resolve link issues or
to clear links changes that have no impact on the requirement status. Track change
information from the Links view of the Requirements Editor.

In this section...
“Enable Change Tracking for Requirements Links” on page 4-5
“Resolve Change Issues for Requirement Links” on page 4-7
“Add Comments to Links” on page 4-8
“Considerations for Using Links Change Tracking” on page 4-8

Enable Change Tracking for Requirements Links

To view the change information for your requirements links:

1 From the Simulink menu, select Analysis > Requirements > Open
Requirements Editor.

2 Open a requirements set.
3 In the Requirements Editor, select the Links view from the View drop-down list.
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4 To enable change tracking from the Requirements Editor, select Display > Change
Information.

The Links view of the Requirements Editor highlights any links with issues in red.

Alternatively, you can enable change tracking for requirement links from the
Requirements Perspective. Right-click an item in the Requirements Perspective and
select Change Information.

The Change Information section for each link details any requirement link change
issues. Simulink Requirements reports any source or destination requirements that have
more recent changes than when the requirement link was established. Simulink
Requirements considers the revision information and time stamp for a requirement item
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when the link was created and the current revision information and time stamp for the
requirement item.

Review Requirements Change Issues from the Requirements View

You can view change issues associated with a particular requirement item from the
Requirements view. When you select a requirement item from the Requirements view
after you “Enable Change Tracking for Requirements Links” on page 4-5, any
requirements items with requirement link change issues are highlighted in red.
Additionally, the requirement link with a change issue is also highlighted in red in the
Links section of the Requirements Editor.

You can click the link icon to the right of requirement link to view the link change issue
and then “Resolve Change Issues for Requirement Links” on page 4-7.

Resolve Change Issues for Requirement Links

If you enable change tracking for requirements links, changes to your requirements that
cause link issues are highlighted in red in the Links view of the Requirements Editor. If
a change has no impact, you can clear the issue to reflect the latest revision of the
requirement. In the Links view of the Requirements Editor:

1 Select the link with a link change issue. In the Change Information section, click
Clear Issue.

 Track Changes to Requirements Links

4-7



2 Alternatively, you can clear all change issues for an entire link set. Right-click the
link set and select Clear All Change Issues.

If the link issue affects the status of your requirements, you can change the model, the
requirements, the test cases, or the links themselves to resolve the discrepancy.

Add Comments to Links
Whenever you resolve link issues, it is good practice to add a comment to the link
describing the action that you took. Each link has a Comments section. To add a
comment:

1 In the Links view of the Requirements Editor, select the link.
2 In the Comments section, select Add Comment.

Considerations for Using Links Change Tracking
Change tracking information updates only when you enable change tracking or when you
manually refresh the change tracking information. To manually refresh the change
tracking information:

• From the Requirements Editor, select Analysis > Refresh Change Information .

From the Requirementes Perspective, or from the Requirements Editor, click the

Refresh current dialog button .

Simulink Requirements only provides change tracking information for link sources that
are resolved when you view the change information.

You can resolve some links by using the Requirements Editor.

1 In the Links view of the Requirements Editor, select the link with an unresolved
link item. The Change Information section shows Unresolved Link Item(s).
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2 To open the link source, click the Source link in the Properties section.

When the link model opens, the link source loads and the Change Information section
displays a resolved link. For more information, see “Review Requirement Links” on page
2-6.

See Also

More About
• “Simulink Project Setup” (Simulink)

 See Also
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Compare Requirements Sets
You can use the “Compare Revisions” (Simulink) tool to compare differences between two
requirements sets.

In this section...
“Compare Two .slreqx Simulink Requirements Sets” on page 4-10
“Review Changes in Source-Controlled Files” on page 4-11

Compare Two .slreqx Simulink Requirements Sets

If you have two versions of a .slreqx Simulink requirements set file, you can use the
Simulink “Compare Revisions” (Simulink) tool to find any differences between the two
files.

Select Both Files to Compare

1 In the Current Folder pane of MATLAB, or in the Project Files View of your
Simulink project, select the first file for comparison.

2 In the Current Folder pane of MATLAB, or in the Project Files View of your
Simulink project, press Ctrl, and then click the second file for comparison.

3 Right-click either file and select Compare Selected Files/Folders.

Select One File and Choose a Second File to Compare

1 In the Current Folder pane of MATLAB, right-click first file and select Compare
Against > Choose.

2 Select the second file for comparison and select Simulink Requirements
Comparison as the Comparison type.

The Simulink comparison tool shows the differences between the two .slreqx
requirements sets.

4 Change Tracking and Team-Based Workflows
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The comparison shows which specific requirements in a requirement set changed, and
which fields of each requirement changed.

Note The comparison tool only shows changes in saved .slreqx requirements sets.
Changes in memory but not yet saved to file are not shown.

To open a requirements item being compared in the Requirements Editor, highlight the
requirements item and click Highlight Now. The requirements item being compared on
the right opens in the Requirements Editor. If you check Always Highlight, the
Requirements Editor opens to the selected requirements item whenever you click on one.

Review Changes in Source-Controlled Files

If you use a separate change management tool to manage changes to your Simulink
projects, you can use the Simulink comparison tool with your source-controlled Simulink
Requirements files. For more information, see “Compare Revisions” (Simulink).
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Report Requirements Information
To document your requirements for review, you can create a report for one or more
requirement sets. You can select the requirements information to contain in the report,
including navigable links to model entities and other requirements. Reports use
Microsoft Word format. If you select multiple requirement sets for reporting, the
information is contained in a single report.

Create a Requirement Report

To create a report:

1 Right-click a requirement set in the Requirements Editor or Requirements Browser,
and select Generate Report.

The Report Generation Options dialog box opens.
2 Set the report filename and location by clicking the Select button next to the

filename.
3 Select report content options.
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4 Select requirement sets to include in the report. The dialog box displays requirement
sets that are loaded in memory. To include a requirement set that does not appear in
the list, first open the requirement set using the Requirements Editor.

5 Click Generate Report.

Report Navigation Links

The requirements report contains links you can use to navigate to model items and other
requirements. For example, this requirement is implemented by two model entities, and
is derived from two requirements. Ctrl+click a link to open the linked item.
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Overview of the Requirements Management Interface (RMI)
If you want to link Simulink and Stateflow objects to requirements, including external
documents, verification objects, or tests, use the RMI to:

• Associate Simulink and Stateflow objects with requirements.
• Create links between Simulink and Stateflow model objects.
• Navigate from a Simulink or Stateflow object to requirements.
• Navigate from an embedded link in a requirements document to the corresponding

Simulink or Stateflow object.
• Review requirements links in your model using highlighting and tags that you define.
• Create reports for your Simulink model that show which objects link to which

requirements.
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Requirements Traceability Links
When you want to navigate from a Simulink model or from a region of MATLAB code to a
location inside a requirements document, you can add requirements traceability links to
the model or code.

Requirements traceability links have the following attributes:

• A description of up to 255 characters.
• A requirements document path name, such as a Microsoft Word file or a module in an

IBM Rational DOORS database. (The RMI supports several built-in document
formats. You can also register custom types of requirements documents. See
“Supported Requirements Document Types” on page 5-7.)

• A designated location inside the requirements document, such as:

• Bookmark
• Anchor
• ID
• Page number
• Line number
• Cell range
• Link target
• Tags that you define

 Requirements Traceability Links
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Requirements Link Storage
When you create links from a model to external requirements, by default, the
Requirements Management Interface (RMI) stores the information about the links
internally in the model file. When links are stored with the model, each time you change
requirements links, the time stamp and version number of the model changes.

If you do not want to modify your model when creating or modifying requirements links,
use external storage for requirements links. External storage is a mechanism for saving
information about linked requirements in a file that is separate from the model file. The
RMI saves information about the requirements links in a file that, by default, is named
model_name.req and is saved in the same folder as the model.

When you use external storage for requirements links, no changes are made to the model
file when you modify the requirements links.

For more information on external storage of requirements links data, see “External
Storage” on page 5-61 and “Guidelines for External Storage of Requirements Links” on
page 5-62.
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Supported Requirements Document Types
The Requirements Management Interface (RMI) supports linking with external
documents of the types listed in the table below. For each supported requirements
document type, the table lists the options for requirements locations within the
document.

If you would like to implement linking with a requirements document of a type that is
not listed in the table below, you can register a custom requirements document type with
the RMI. For more information, see “Create a Custom Requirements Link Type” on page
5-184.
Requirements
Document Type

Location Options

Microsoft Word
2003 or later

• Named item — A bookmark name. The RMI links to the location
of that bookmark in the document. The most stable location
identifier because the link is maintained when the target content
is modified or moved.

• Search text — A search string. The RMI links to the first
occurrence of that string in the document. This search is not case
sensitive.

• Page/item number — A page number. The RMI links to the top
of the specified page.

Microsoft Excel
2003 or later

• Named item — A named range of cells. The RMI links to that
named item in the workbook. The most stable location identifier
because the link is maintained when the target content is
modified or moved.

• Search text — A search string. The RMI links to the first
occurrence of that string in the workbook. This search is not case
sensitive.

• Sheet range — A cell location in a workbook:

• Cell number (A1, C13)
• Range of cells (C5:D7)
• Range of cells on another worksheet (Sheet1!A1:B4)

The RMI links to that cell or cells.

 Supported Requirements Document Types
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Requirements
Document Type

Location Options

IBMRationalDOO
RS

Page/item number — The unique numeric ID of the target
DOORS object. The RMI links to that object.

MuPAD® Named item — The name of a link target in a MuPAD notebook.
Simulink
DocBlock block
(RTF format only)

Create links to the RTF file associated with the DocBlock block to a
Microsoft Word file:

• Search text — A search string. The RMI links to the first
occurrence of that string in the document. This search is not case
sensitive.

• Named item — A bookmark name. The RMI links to the location
of that bookmark in the document.

• Page/item number — A page number. The RMI links to the top
of that page.

Text • Search text — A search string. The RMI links to the first
occurrence of that string within the document. This search is not
case sensitive.

• Line number — A line number. The RMI links to the beginning
of that line.

HTML You can link only to a named anchor.

For example, in your HTML requirements document, if you define
the anchor

    <A NAME=valve_timing> ...contents... </A>

in the Location field, enter valve_timing or, from the document
index, choose the anchor name.

Select the Document Index tab in the “Requirements Traceability
Link Editor” on page 5-20 to see available anchors in an HTML file.
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Requirements
Document Type

Location Options

Web browser URL The RMI can link to a URL location. In the Document field, type
the URL string. When you click the link, the document opens in a
Web browser:

• Named item — An anchor name. The RMI links to that location
on the Web page at that URL.

PDF Navigation will open a PDF document but will not scroll to a specific
page or bookmark.

The RMI cannot create a document index of bookmarks in PDF files.
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Supported Model Objects for Requirements Linking
You can associate requirements links between the following types of Simulink model
objects:

• Simulink block diagrams and subsystems
• Simulink blocks and annotations
• Simulink data dictionary entries
• Signal Builder signal groups
• Stateflow charts, subcharts, states, transitions, and boxes
• Stateflow functions
• Lines of MATLAB code
• Simulink Test Manager test cases
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Selection-Based Linking
You can use selection-based linking to create links from a model object to another model
object or to an object in a requirements document. Selection-based linking is the easiest
way to create requirements links from a model to an external document.

For examples of selection-based linking, see “Link to Requirements Document Using
Selection-Based Linking” on page 5-12 and “Link Multiple Model Objects to a
Requirements Document” on page 5-28.

 Selection-Based Linking
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Link to Requirements Document Using Selection-Based Linking
To create a link from a model to a requirements document, using selection-based linking:

1 In the requirements document, select text or objects to link to.
2 Right-click the model object. Select Requirements Traceability and then the

option that corresponds to one of the types for which selection-based linking is
available:

• Link to Selection in MATLAB
• Link to Selection in Word
• Link to Selection in Excel
• Link to Selection in DOORS
• Select for Linking with Simulink
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Link Test Cases to Requirements Documents
Since requirements specify behavior in response to particular conditions, you can build
test cases (test inputs, expected outputs, and assessments) from the model requirements.
Test cases reproduce specific conditions using test inputs, and assess the actual model
output against the expected outputs. As you develop the model, build test files that check
system behavior and link them to corresponding requirements. By defining these test
cases in test files, you can periodically check your model and archive results to
demonstrate model stability.

Establish Requirements Traceability for Testing

If you have a Simulink Test and a Simulink Requirements license, you can link
requirements to test harnesses, test sequences, and test cases. Before adding links,
review “Supported Requirements Document Types” on page 5-7 and “Requirements
Management Interface”.

Requirements Traceability for Test Harnesses

When you edit requirements links to the component under test, the links immediately
synchronize between the test harness and the main model. Other changes to the
component under test, such as adding a block, synchronize when you close the test
harness. If you add a block to the component under test, close and reopen the harness to
update the main model before adding a requirement link.

To view items with requirements links, select Analysis > Requirements Traceability
> Highlight Model.

Requirements Traceability for Test Sequences

In test sequences, you can link to test steps. To create a link, first find the model item,
test case, or location in the document you want to link to. Right-click the test step, select
Requirements Traceability, and add a link or open the link editor.

To highlight or unhighlight test steps that have requirements links, toggle the

requirements links highlighting button  in the Test Sequence Editor toolstrip.
Highlighting test steps also highlights the model block diagram.
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Requirements Traceability for Test Cases

If you use many test cases with a single test harness, link to each specific test case to
distinguish which blocks and test steps apply to it. To link test steps or test harness
blocks to test cases,

1 Open the test case in the Test Manager.
2 Highlight the test case in the test browser.
3 Right-click the block or test step, and select Requirements Traceability > Link to

Current Test Case.

Requirements Traceability Example

This example demonstrates adding requirements links to a test harness and test
sequence. The model is a component of an autopilot roll control system. This example
requires Simulink Test and Simulink Requirements.

1 Open the test file, the model, and the harness.

open AutopilotTestFile.mldatx,
open_system RollAutopilotMdlRef,
sltest.harness.open('RollAutopilotMdlRef/Roll Reference',...
'RollReference_Requirement1_3')

2 In the test harness, select Analysis > Requirements Traceability > Highlight
Model.

The test harness highlights the Test Sequence block, component under test, and Test
Assessment block.
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3 Add traceability to the Discrete Derivative block.

a Right-click the Discrete Derivative block and select Requirements
Traceability > Open Link Editor.

b In the Requirements tab, click New.
c Enter the following to establish the link:

• Description: DD link
• Document type: Text file
• Document: RollAutopilotRequirements.txt
• Location: 1.3 Roll Hold Reference

d Click OK. The Discrete Derivative block highlights.
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4 To trace to the requirements document, right-click the Discrete Derivative block, and
select Requirements Traceability > DD Link. The requirements document opens
in the editor and highlights the linked text.

5 Open the Test Sequence block. Add a requirements link that links the
InitializeTest step to the test case.

a In the Test Manager, highlight Requirement 1.3 Test in the test browser.
b Right-click the InitializeTest step in the Test Sequence Editor. Select

Requirements Traceability > Link to Current Test Case.

When the requirements link is added, the Test Sequence Editor highlights the
step.
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Configure RMI for Interaction with Microsoft Office Applications
and IBM Rational DOORS Software

The Requirements Management Interface (RMI) must communicate with external
software products such as Microsoft Office and IBM Rational DOORS software to
establish links between requirements and Simulink model elements.

Perform initial configuration steps to setup the RMI if you want to:

• Use ActiveX® controls for navigation from Microsoft Office documents to Simulink
models (PC only).

• Use the RMI with IBM Rational DOORS software (PC only).
• Use the RMI with IBM Rational DOORS Next Generation web server.

Configure RMI for Microsoft Office Interaction

When you work with older requirements documents that include ActiveX controls
inserted by previous versions of Simulink, registerActiveX controls. More recent versions
of Simulink use HTTP hyperlinks to navigate from Microsoft Office to Simulink.

1 Run MATLAB as an administrator.
2 At the command prompt, enter:

rmi setup
3 To register the current MATLAB installation as an ActiveX Automation Server,

press Y.

Configure RMI for IBM Rational DOORS Interaction

If you have IBM Rational DOORS installed, you must configure it to communicate with
MATLAB.

1 Run MATLAB as an administrator.
2 At the command prompt, enter:

rmi setup
3 Skip the ActiveX Automation Server setup by pressing N.

The IBM Rational DOORS-MATLAB Interface setup utility opens.

 Configure RMI for Interaction with Microsoft Office Applications and IBM Rational DOORS Software
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4 If the detected path to your IBM Rational DOORS installation is correct, configure
the software to communicate with MATLAB by pressing 1.

5 If MATLAB did not detect your IBM Rational DOORS installation in the previous
step, enter the installation folder by pressing 2.

Note You can directly access the IBM Rational DOORS-MATLAB Interface setup utility.
At the command prompt, enter:

rmi setup doors

Configure RMI for IBM Rational DOORS Next Generation Interaction
1 At the command prompt, enter:

rmi setup
2 You do not need to set up the ActiveX Automation Server because it is not required

for requirements linking with IBM Rational DOORS Next Generation. Skip this step
by pressing N.

3 If you have IBM Rational DOORS installed, you are prompted to select the
installation path to configure for communication with MATLAB. If you are using
RMI with IBM Rational DOORS Next Generation only, you do not need to configure
IBM Rational DOORS. Skip this step by pressing by pressing 3.

4 Configure RMI for integration with IBM Rational DOORS Next Generation server by
pressing Y.

5 Complete the setup by entering the IBM Rational DOORS Next Generation Server
Address and the Port Number in the next prompt.

Install the Selection for Simulink Widget in IBM Rational DOORS Next Generation

Installing the Selection for Simulink widget enables you to propagate selection
information from IBM Rational DOORS Next Generation to MATLAB.

In the Windows® File Explorer, navigate to the folder toolbox\slrequirements
\slrequirements\resources in your MATLAB installation folder. Copy the
dngsllink folder into the extensions subfolder of your IBM Rational DOORS Next
Generation installation. The location of this folder depends on your server version.

After copying the dngsllink folder to your server, add the Selection for Simulink
widget to the Mini Dashboard in IBM Rational DOORS Next Generation. In the Mini
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Dashboard, select Add Widget > Add OpenSocial Gadget. Specify the URL to
dngsllink.xml that corresponds to the extensions\dngsllink subfolder in your
server installation folder.

For example, if you have Liberty server version 6.0.2 installed, the extensions
subfolder is located in: JazzTeamServer_6.0.02\server\liberty\servers\clm
\dropins\war\extensions. The corresponding URL for adding the widget is:
https://JAZZSERVERNAME:9443/extensions/dngsllink/dngsllink.xml.
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Requirements Traceability Link Editor
In this section...
“Manage Requirements Traceability Links Using Link Editor” on page 5-20
“Requirements Tab” on page 5-22
“Document Index Tab” on page 5-22

Manage Requirements Traceability Links Using Link Editor

You can create, edit, and delete requirements traceability links using the Link Editor. To
open the Link Editor:

• in the Simulink Editor, right-click on a model object that has a requirements
traceability link. From the context menu, select Requirements Traceability >
Open Link Editor.

• in the MATLAB Editor, right-click inside a region of code that has a requirements
traceability link. From the context menu, select Requirements Traceability >
Open Link Editor.

The Link Editor opens, as shown below.
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In the Link Editor, you can:

• Create requirements links from one or more Simulink model objects or MATLAB code
lines.

• Customize information about requirements links, including specifying user tags to
filter requirements highlighting and reporting.

• Delete existing requirements links.
• Modify the stored order of requirements to control the order of labels in context

menus for linked objects.
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Requirements Tab

On the Requirements tab, you specify detailed information about the link, including:

• Description of the requirement (up to 255 words). If you create a link using the
document index, unless a description already exists, the name of the index location
becomes the description for the link .

• Path name to the requirements document.
• Document type (Microsoft Word, Microsoft Excel, IBM Rational DOORS, MuPAD,

HTML, text file, etc.).
• Location of the requirement (search text, named location, or page or item number).
• User-specified tag or keyword.

Document Index Tab

The Document Index tab is available only if you have specified a file in the Document
field on the Requirements tab that supports indexing. On the Document Index tab,
the RMI generates a list of locations in the specified requirements document for the
following types of requirements documents:

• Microsoft Word
• IBMRationalDOORS
• HTML files
• MuPAD

Note The RMI cannot create document indexes for PDF files.

From the document index, select the desired requirement from the document index and
click OK. Unless a description already exists, the name of the index location becomes the
description for the link.

If you make any changes to your requirements document, to load any newly created
locations into the document index, you must click Refresh. During a MATLAB session,
the RMI does not reload the document index unless you click the Refresh button.
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Requirements Settings
You can manage your RMI preferences in the Requirements Settings dialog box. These
settings are global and not associated with any particular model. To open the
Requirements Settings dialog box, from the Simulink Editor, select Analysis >
Requirements Traceability > Settings. In this dialog box, you can select the:

• Storage tab to set the default way in which the RMI stores requirements links in a
model. For storage information, see “Specify Storage for Requirements Links” on page
5-63.

• Selection Linking tab to set the options for linking to the active selection in a
supported document. For setting information, see “Selection Linking Tab” on page 5-
23.

• Filters tab to set the options for filtering requirements in a model. For filtering
information, see “Configure Requirements Filtering” on page 5-95.

• Report tab to customize the requirements report without using the Report
Generator. For setting information, see “Customize Requirements Report Using the
RMI Settings” on page 5-83.

Selection Linking Tab

In the Requirements Settings dialog box, on the Selection Linking tab, use the
following options for linking to the active selection in a supported document. To open the
Requirements Settings dialog box, select Analysis > Requirements Traceability >
Settings.
Options Description
For linking to the active selection within an external document:
Enabled applications Enable selection-based linking shortcuts to

Microsoft Word, Microsoft Excel, or
DOORS applications.

Document file reference Select type of file reference. For
information on what settings to use, see
“Document Path Storage” on page 5-113.
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Options Description
Apply this user tag to new links Enter text to attach to the links you create.

For more information about user tags, see
“Filter Requirements with User Tags” on
page 5-90.

When creating selection-based links:
Modify destination for bidirectional
linking

Creates links both to and from selected link
destination.

Store absolute path to model file Select type of file reference. For
information, see “Document Path Storage”
on page 5-113.

Use custom bitmap for navigation
controls in documents

Select and browse for your bitmap. You can
use your own bitmap file to control the
appearance of navigation links in your
document.

Use ActiveX buttons in Word and
Excel (backward compatibility)

Select to use legacy ActiveX controls to
create links in Microsoft Word and
Microsoft Excel applications. By default, if
not selected, you create URL-based links.
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Link Model Objects

In this section...
“Link Objects in the Same Model” on page 5-25
“Link Objects in Different Models” on page 5-25

Link Objects in the Same Model

You can create a requirements link from one model object to another model object:

1 Right-click the link destination model object and select Requirements
Traceability > Select for Linking with Simulink.

2 Right-click the link source model object and select Requirements Traceability >
Add Link to Selected Object.

3 Right-click the link source model object again and select Requirements
Traceability. The new link appears at the top of the Requirements Traceability
submenu.

Link Objects in Different Models

You can create links between objects in related models. This example shows how to link
model objects in slvnvdemo_powerwindow_controller and
slvnvdemo_powerwindow.

1 Open the slvnvdemo_powerwindow_controller and slvnvdemo_powerwindow
models.

2 In the slvnvdemo_powerwindow model window, double-click the
power_window_control_system subsystem. The
power_window_control_system subsystem opens.

3 In the slvnvdemo_powerwindow/power_window_control_system subsystem
window, right-click the control subsystem. Select Requirements Traceability >
Select for Linking with Simulink.

4 In the slvnvdemo_powerwindow_controller model window, right-click the
control subsystem. Select Requirements Traceability > Add Link to Selected
Object.
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5 Right-click the slvnvdemo_powerwindow_controller/control subsystem and
select Requirements Traceability. The new RMI link appears at the top of the
Requirements Traceability submenu.

6 To verify that the links were created, in the
slvnvdemo_powerwindow_controller model window, select Analysis >
Requirements Traceability > Highlight Model.

The blocks with requirements links are highlighted.
7 Close the slvnvdemo_powerwindow_controller and slvnvdemo_powerwindow

models.
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Link from External Applications
You can navigate to Simulink objects or MATLAB code with requirements using the
internal MATLAB HTTP server.

To get the URL for an object in your model, right-click the object and select
Requirements Traceability > Copy URL to Clipboard. Note that if your model
stores requirements traceability data internally, when you select Requirements
Traceability > Copy URL to Clipboard, the Requirements Management Interface
(RMI) creates a unique identifier in the model file. To enable navigation with the URL
that you copied, resave your model. To use URLs that do not require changes to your
model, configure your model for external storage of requirements traceability data. For
more information, see “Move Internally Stored Requirements Links to External Storage”
on page 5-66.

To get the URL for a line or lines of MATLAB code, in the MATLAB Editor, select the
region of code you want to link to and right-click. From the context menu, select
Requirements Traceability > Copy Link to Clipboard.

You can then paste the URL into an external application and use it to navigate back to
the corresponding object in your model.

To enable navigation with these links, the internal MATLAB HTTP server must be
activated on your local host. Selecting Requirements Traceability > Copy URL to
Clipboard activates the internal HTTP server. You can also enter the command
rmi('httpLink') at the MATLAB command prompt to activate the internal HTTP
server.
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Link Multiple Model Objects to a Requirements Document
You can link multiple Simulink and Stateflow objects to a requirement. The workflow is:

1 In the requirements document, select the requirement.
2 In the Simulink Editor or Stateflow Editor, select the objects to link to the selected

requirement. You can select multiple objects by holding down the Shift key while
you click each object that you want to select. Note that you can only select multiple
objects in the same diagram.

3 Right-click one of the selected objects to open the context menu and hover over
Requirements Traceability.

4 Select one of the selection-based linking options:

• Link to Selection in MATLAB
• Link to Selection in Word
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• Link to Selection in Excel
• Link to Selection in DOORS

5 You can also add and edit links for multiple objects using the Requirements
Traceability Link Editor. To open the Link Editor, in the Requirements
Traceability context menu, select Add Links to All.
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Link Multiple Model Objects to a Requirement Document Using a
Simulink DocBlock

This example shows how to link multiple model objects to a requirement document using
a DocBlock.

You can minimize the number of links to the external requirements document by using a
DocBlock in the model. You can insert aDocBlock at the top level of the model and link
your external requirements document to it. Then you can link the DocBlock to all objects
in the model that are relevant to the requirement in the external document.

1 Open the example model:

slvnvdemo_fuelsys_officereq
2 Open a requirements document associated with that model:

rmi('view','slvnvdemo_fuelsys_officereq',1);
3 Insert a Simulink DocBlock into the model.
4 Right-click DocBlock and select Mask Parameters. The Block Parameters:

DocBlock dialog box opens.
5 In the Block Parameters: DocBlock dialog box Document type drop-down list, select

RTF.
6 Click Apply or OK to create the link.
7 In slvnvdemo_FuelSys_DesignDescription.docx, find and select the section

titled 2.2 Determination of pumping efficiency.
8 In the slvnvdemo_fuelsys_officereq model window, right-click the DocBlock

and select Requirements Traceability > Link to Selection in Word.

The RMI inserts a bookmark at that location in the requirements document.
9 In the slvnvdemo_fuelsys_officereq model window, right-click the DocBlock

and select Requirements Traceability > Select for Linking with Simulink.
10 In the slvnvdemo_fuelsys_officereq/fuel rate controller subsystem

window, select the control logic chart and the Airflow calculation
subsystems. Use the shift key to select both.

11 Right-click the Airflow calculation subsystem and select Requirements
Traceability > Add Link to Selected Object.
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12 In the slvnvdemo_fuelsys_officereq model window, select DocBlock, right-
click, and select Requirements Traceability.

The link to the new requirements are on the top menu option.
13 To verify that the links were created, select Analysis > Requirements

Traceability > Highlight Model.

The DocBlock, control logic chart, and Airflow calculation subsystem are
highlighted.

14 Close the slvnvdemo_fuelsys_officereq model and the
slvnvdemo_FuelSys_DesignDescription.docx requirements document.
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Link to Requirements in Microsoft Word Documents

In this section...
“Create Bookmarks in a Microsoft Word Requirements Document” on page 5-32
“Open the Example Model and Associated Requirements Document” on page 5-34
“Create a Link from a Model Object to a Microsoft Word Requirements Document” on
page 5-35

Create Bookmarks in a Microsoft Word Requirements Document

You can create bookmarks in your Microsoft Word requirements documents to identify
the requirements that you want to link to. When you create the links, you specify that
the RMI must link to an existing bookmark, rather than create a new bookmark.

This approach offers advantages to creating new bookmarks:

• You can give the bookmarks meaningful names that represent the content of the
requirement.

• When the RMI creates the links, it does not modify your requirements document.

Note When you link to an existing bookmark, navigating the link highlights the entire
range of the existing bookmark. Therefore, when you create a bookmark for requirement
linking, make sure to select only the document information relevant to your requirement.

If you have a requirements document containing bookmarks, follow these steps to create
requirements links from your Simulink model to the bookmarks:

1 Open your model.
2 Open your Microsoft Word requirements document that contains bookmarks that

identify requirements.
3 Right-click a block in the model that you want to link to a requirement and select

Requirements Traceability > Open Link Editor

The Requirements Traceability Link Editor opens.
4 Click New.
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5 Click Browse and navigate to the Microsoft Word requirements document that has
bookmarks.

6 Open the document. The RMI populates the Document and Document type fields.
7 Click the Document Index tab of the Link Editor.

The Document Index tab lists all bookmarks in the requirements document, as
well as all section headings (text that you have styled as Heading 1, Heading 2,
and so on).

The document index lists the bookmarks in alphabetical order, not in order of
location within the document.
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8 Select the bookmark that you want to link the block to and click OK.

The RMI creates a link from the block to the location of the bookmark in the
requirements document without modifying the document itself.

Open the Example Model and Associated Requirements Document

This example describes how to create links from objects in a Simulink model to selected
requirements text in a Microsoft Word document.
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Navigate from the model to the requirements document:

1 Open the example model:

slvnvdemo_fuelsys_officereq
2 Open a requirements document associated with that model:

rmi('view','slvnvdemo_fuelsys_officereq',1);

Keep the example model and the requirements document open.

Create a Link from a Model Object to a Microsoft Word Requirements
Document

Create a link from the Airflow calculation subsystem in the
slvnvdemo_fuelsys_officereq model to selected text in the requirements document:

1 In slvnvdemo_FuelSys_DesignDescription.docx, find the section titled 2.2
Determination of pumping efficiency.

2 Select the header text.
3 Open the example model:

slvnvdemo_fuelsys_officereq
4 Select Analysis > Requirements Traceability > Settings. The Requirements

Settings dialog box opens.
5 On the Selection Linking tab of the Requirements Settings dialog box:

• Set the Document file reference option to path relative to model
folder.

• Enable Modify destination for bidirectional linking.

When you select this option, every time you create a selection-based link from a
model object to a requirement, the RMI inserts navigation objects at the
designated location.

For more information about the settings, see “Requirements Settings” on page 5-23.
6 Double-click the fuel rate controller subsystem to open it.
7 Open the Airflow calculation subsystem.
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8 Right-click the Pumping Constant block and select Requirements Traceability >
Link to Selection in Word.

The RMI inserts a bookmark at that location in the requirements document and
assigns it a generic name, in this case, Simulink_requirement_item_7.

Note You cannot link to a Microsoft Word document from a model object if you run
either one of MATLAB or Microsoft Word as an Administrator. Run both software
with the same privilege level to link to Microsoft Word requirements documents.

9 To verify that the link was created, select Analysis > Requirements Traceability
> Highlight Model.

The Pumping Constant block, and other blocks with requirements links, are
highlighted.

10 To navigate to the link, right-click the Pumping Constant block and select
Requirements Traceability > 1. “Determination of pumping efficiency”.

The section 2.2 Determination of pumping efficiency is displayed, selected in
the requirements document.

Keep the example model and the requirements document open.

View Link Details

To view the details of the link that you just created, right-click the Pumping Constant
block and select Requirements Traceability > Open Link Editor.

The Requirements Traceability Link Editor opens.
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This dialog box contains the following information for the link you just created:

• Description of the link, which for selection-based links, matches the text of the
selected requirements document, in this case Determination of pumping
efficiency.

• Name of the requirements document, in this case
slvnvdemo_FuelSys_DesignDescription.docx.

• Document type, in this case, Microsoft Word.
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• The type and identifier of the location in the requirements document. With selection-
based linking for Microsoft Word requirements documents, the RMI creates a
bookmark in the requirements document. For this link, the RMI created a bookmark
named Simulink_requirement_item_7.

If you do not want the RMI to modify the Microsoft Word requirements document
when it creates links, create bookmarks in your Microsoft Word file, as described in
“Create Bookmarks in a Microsoft Word Requirements Document” on page 5-32.

• User tag, a user-defined keyword. This link does not have a user tag.

Note For more information about user tags, see “Filter Requirements with User Tags”
on page 5-90.
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Link to Requirements in IBM Rational DOORS Databases
This example shows how to create links from objects in a Simulink model to
requirements in an IBM Rational DOORS database.

1 Open a DOORS formal module.
2 Click to select one of the requirement objects.
3 Open the example model:

sldemo_fuelsys
4 Open the fuel_rate_control subsystem.
5 Right-click the airflow_calc subsystem and select Requirements Traceability >

Link to Selection in DOORS.
6 To confirm the requirement link, right-click the airflow_calc subsystem and select

Requirements Traceability. In the submenu, the top item is the heading text for
the DOORS requirement object.
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If you navigate to a DOORS requirement, the DOORS module opens in read only
mode. If you want to modify the DOORS module, open the module using DOORS
software.

Note To view an example of using the RMI with an IBM Rational DOORS database, run
the Managing Requirements for Fault-Tolerant Fuel Control System (IBM Rational
DOORS) example at the MATLAB command prompt.
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Link to Requirements in Microsoft Excel Workbooks

In this section...
“Navigate from a Model Object to Requirements in a Microsoft Excel Workbook” on page
5-41
“Create Requirements Links to the Workbook” on page 5-41
“Link Multiple Model Objects to a Microsoft Excel Workbook” on page 5-42
“Change Requirements Links” on page 5-43

Navigate from a Model Object to Requirements in a Microsoft Excel
Workbook
1 Open the example model:

slvnvdemo_fuelsys_officereq
2 Select Analysis > Requirements Traceability > Highlight Model to highlight

the model objects with requirements.
3 Right-click the Test inputs Signal Builder block and select Requirements

Traceability > 1. “Normal mode of operation”.

The slvnvdemo_FuelSys_TestScenarios.xlsx file opens, with the associated
cell highlighted.

Keep the example model and Microsoft Excel requirements document open.

For information about creating requirements links in Signal Builder blocks, see “Link
Signal Builder Blocks to Requirements Documents” on page 5-52.

Create Requirements Links to the Workbook
1 At the top level of the slvnvdemo_fuelsys_officereq model, right-click the

speed sensor block and select Requirements Traceability > Open Link Editor.

The Requirements Traceability Link Editor opens.
2 To create a requirements link, click New.
3 In the Description field, enter:
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Speed sensor failure

You will link the speed sensor block to the Speed Sensor Failure information in
the Microsoft Excel requirements document.

4 When you browse and select a requirements document, the RMI stores the document
path as specified by the Document file reference option on the Requirements
Settings dialog box, Selection Linking tab.

For information about which setting to use for your working environment, see
“Document Path Storage” on page 5-113.

5 At the Document field, click Browse to locate and open the
slvnvdemo_FuelSys_TestScenarios.xlsx file.

The Document Type field information changes to Microsoft Excel.
6 In the workbook, the Speed sensor failure information is in cells B22:E22. For the

Location (Type/Identifier) field, select Sheet range and in the second field,
enter B22:E22. (The cell range letters are not case sensitive.)

7 Click Apply or OK to create the link.
8 To confirm that you created the link, right-click the speed sensor block and select

Requirements Traceability > 1. “Speed sensor failure”.

The workbook opens, with cells B22:E22 highlighted.

Keep the example model and Microsoft Excel requirements document open.

Link Multiple Model Objects to a Microsoft Excel Workbook
You can use the same technique to link multiple Simulink and Stateflow objects to a
requirement in a Microsoft Excel workbook. The workflow is:

1 In the model window, select the objects to link to a requirement.
2 Right-click one of the selected objects and select Requirements Traceability >

Open Link Editor.
3 When you browse and select a requirements document, the RMI stores the document

path as specified by the Document file reference option on the Requirements
Settings dialog box, Selection Linking tab.

For information about which setting to use for your working environment, see
“Document Path Storage” on page 5-113.
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4 Use the Link Editor to specify information about the Microsoft Excel requirements
document, the requirement, and the link.

5 Click Apply or OK to create the link.

Change Requirements Links
1 In the slvnvdemo_fuelsys_officereq model, right-click the MAP sensor block

and select Requirements Traceability > Open Link Editor.

The Requirements Traceability Link Editor opens displaying the information about
the requirements link.
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2 In the Description field, enter:

MAP sensor test scenario

The User tag field contains the tag test. User tags filter requirements for
highlighting and reporting.

Note For more information about user tags, see “Filter Requirements with User
Tags” on page 5-90.
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3 Click Apply or OK to save the change.

Keep the example model open.
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Link to Requirements in MuPAD Notebooks
This example shows how to create a link from a Simulink model to a MuPAD notebook.
You use a model that simulates a nonlinear second-order system with the van der Pol
equation.

Before beginning this example, create a MuPAD notebook with one or more link targets.
This example uses a MuPAD notebook that includes information about solving the van
der Pol equation symbolically and numerically.

Note You must have the Symbolic Math Toolbox™ installed on your system to open a
MuPAD notebook. For information about creating or opening MuPAD notebooks, see
“Create MuPAD Notebooks” (Symbolic Math Toolbox) and “Open MuPAD Notebooks”
(Symbolic Math Toolbox).

1 Open an example model for the van der Pol equation:

vdp
2 Right-click a blank area of the model and select Requirements Traceability at

This Level > Open Link Editor.

You are adding the requirement to the model itself, not to a specific block in the
model.

3 Click New.
4 In the Document type drop-down list, select MuPAD Notebook.
5 When you browse and select a requirements document, the RMI stores the document

path as specified by the Document file reference option on the Requirements
Settings dialog box, Selection Linking tab.

For information about which setting to use for your working environment, see
“Document Path Storage” on page 5-113.

6 Click Browse to navigate to the notebook that you want to use.

Use a notebook that has link targets in it.
7 Make sure that the MuPAD notebook is in a saved state. Any link targets created

since the last save do not appear in the RMI document index.
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8 To list the link targets, in the Requirements Traceability Link Editor, click the
Document Index tab.

This figure shows two link targets.

Note These link targets are in a MuPAD notebook that was created for this example.
The Document Index tab displays only link targets that you have created in your
MuPAD notebook.

9 Select a link target name and click Apply.
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The Requirements tab reopens, displaying the details of the newly created link.
Unless you have previously entered a description, the link target name appears in
the Description field.

10 To confirm that you created the link, right-click a blank area of the model and select
Requirement. The new link is at the top of the submenu.
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Create Requirements Traceability Report for Model
To create the default requirements report for a Simulink model:

1 Open the example model:
slvnvdemo_fuelsys_officereq

2 Make sure that your current working folder is writable.
3 In the Simulink Editor, select Analysis > Requirements Traceability >

Generate Report.

If your model is large and has many requirements links, it takes a few minutes to
create the report.

A Web browser window opens with the contents of the report. The following graphic
shows the Table of Contents for the slvnvdemo_fuelsys_officereq model.

A typical requirements report includes:
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• Table of contents
• List of tables
• Per-subsystem sections that include:

• Tables that list objects with requirements and include links to associated
requirements documents

• Graphic images of objects with requirements
• Lists of objects with no requirements
• MATLAB code lines with requirements in MATLAB Function blocks

For detailed information about requirements reports, see “Customize Requirements
Traceability Report for Model” on page 5-73.

If Your Model Has Library Reference Blocks

To include requirements links associated with library reference blocks, you must select
Include links in referenced libraries and data dictionaries under the Report tab
of the Requirements Settings, as described in “Customize Requirements Report” on
page 5-83.

If Your Model Has Model Reference Blocks

By default, requirements links within model reference blocks in your model are not
included in requirements traceability reports. To generate a report that includes
requirements information for referenced models, follow the steps in “Report for
Requirements in Model Blocks” on page 5-81.
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Requirements Linking with Simulink Annotations
You can create requirements links to and from Simulink.Annotation objects using the
Requirements Management Interface (RMI). Annotations are free-floating text boxes
that you can place inside a Simulink model. For more information, see “Describe Models
Using Annotations” (Simulink). You can use RMI linking to associate annotations with
other Simulink objects or external requirements documents. Note that requirements
linking for annotations is not supported in Stateflow.

Requirements linking for Simulink annotations is enabled only if you configure your
model to store requirements data externally. To specify external storage of requirements
data for a model, in the Requirements Settings dialog box under Storage > Default
storage location for requirements links data, select Store externally (in a
separate *.req file). If you have an existing model that contains internally stored
requirements links, you must convert the model to store requirements data externally
before you can use requirements linking for annotations in the model. To switch the
model from internal to external RMI storage, move all existing requirements links in it to
an external .req file by selecting Analysis > Requirements Traceability > Move to
File. For more information on requirements links storage, see “Specify Storage for
Requirements Links” on page 5-63.

Note If you later change your model to store requirements links internally as described
in “Move Externally Stored Requirements Links to the Model File” on page 5-67, or if
you save the model in a version of MATLAB prior to R2012b, annotation requirements
links are either discarded or attached to a corresponding parent diagram.

Annotations are context-specific. Unlike copying other Simulink objects, copying an
annotation does not copy its associated requirements links. Requirements links from
annotations do not appear in generated code, but requirements links to annotations from
other Simulink objects do appear.
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Link Signal Builder Blocks to Requirements Documents
You can create links from a signal group in a Signal Builder block to a requirements
document:

1 Open the model:

sf_car
2 In the sf_car model window, double-click the User Inputs block.

The Signal Builder dialog box opens, displaying four groups of signals. The Passing
Maneuver signal group is the current active group. The RMI associates any
requirements links that you add to the current active signal group.

3 At the far-right end of the toolbar, click the Show verification settings button .
(You might need to expand the Signal Builder dialog box for this button to become
visible.)

A Requirements pane opens on the right-hand side of the Signal Builder dialog
box.

4 Place your cursor in the window, right-click, and select Open Link Editor.

The Requirements Traceability Link Editor opens.
5 Click New. In the Description field, enter User input requirements.
6 When you browse and select a requirements document, the RMI stores the document

path as specified by the Document file reference option on the Requirements
Settings dialog box, Selection Linking tab.

For information about which setting to use for your working environment, see
“Document Path Storage” on page 5-113.

7 Browse to a requirements document and click Open.
8 In the Location drop-down list, select Search text to link to specified text in the

document.

5 Requirements Management Interface

5-52



9 Next to the Location drop-down list, enter User Input Requirements.
10 Click Apply to create the link.
11 To verify that the RMI created the link, in the Simulink Editor, select the User

Inputs block, right-click, and select Requirements Traceability.

The link to the new requirement is the option at the top of the submenu.
12 Save the sf_car_linking model.

Note Links that you create in this way associate requirements information with
individual signal groups, not with the entire Signal Builder block.

In this example, switch to a different active group in the drop-down list to link a
requirement to another signal group.
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Link Signal Builder Blocks to Model Objects
This example shows how to create links from a signal group in a Signal Builder block to a
model object:

1 Open the sf_car model.
2 Open the sf_car/shift_logic chart.
3 Right-click upshifting and select Requirements Traceability > Select for

Linking with Simulink.
4 In the sf_car model window, double-click the User Inputs block.

The Signal Builder dialog box opens, displaying four groups of signals. The Passing
Maneuver signal group is the current active group. The RMI associates any
requirements links that you add to the current active signal group.

5 In the Signal Builder dialog box, click the Gradual Acceleration tab.
6 At the far-right end of the toolbar, click the Show verification settings button .

(You might need to expand the Signal Builder dialog box for this button to become
visible.)

A Requirements pane opens on the right-hand side of the Signal Builder dialog
box.

7 Place your cursor in the window, right-click, and select Open Link Editor.

The Requirements Traceability Link Editor opens.
8 Click New. In the Description field, enter Upshifting.
9 In the Document type field, select Simulink. Click Use current. The software

fills in the field with the Location: (Type/Identifier) information for upshifting.
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10 Click Apply to create the link.
11 In the model window, select the User Inputs block, right-click, and select

Requirements Traceability.

The link to the new requirement is the option at the top of the submenu.
12 To verify that the links were created, in the sf_car model window, select Analysis

> Requirements Traceability > Highlight Model.

The blocks with requirements links are highlighted.

Note Links that you create in this way associate requirements information with
individual signal groups, not with the entire Signal Builder block.

13 Close the sf_car model.
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Link Requirements to Simulink Data Dictionary Entries
You can create requirements traceability links for entries in Simulink data dictionaries.
The process is similar to linking for other model objects. In the Model Explorer, right-
click a data dictionary entry, select Requirements Traceability, and choose one of the
selection-based linking options. You can also use the Link Editor.

This example demonstrates linking to a data dictionary entry.

1 Enter sldemo_fuelsys_dd_controller at the command line to open
sldemo_fuelsys_dd_controller.

2 Open the linked data dictionary by clicking the data dictionary badge in the bottom
left corner of the model.

3 In the Model Hierarchy pane of the Model Explorer, select Design Data in the
sldemo_fuelsys_dd_controller data dictionary.

4 You will link the PumpCon parameter to the Pumping Constant lookup table in the
model.
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5 Open the airflow_calc subsystem and select the Pumping Constant lookup
table.

6 In the Model Explorer, right-click the PumpCon parameter and select
Requirements Traceability > Link to Selection in Simulink.

The two objects are linked.
7 Check the link. Right-click the PumpCon parameter and select Requirements

Traceability, then select the navigation shortcut at the top of the Requirements
Traceability submenu. Simulink highlights the lookup table.

 Link Requirements to Simulink Data Dictionary Entries

5-57



Requirements Traceability with IBM Rational DOORS Next
Generation

In this section...
“Link to Requirements in IBM Rational DOORS Next Generation” on page 5-58
“Navigate to Requirements from Simulink” on page 5-60

You can link and trace Simulink model elements to requirements in IBM Rational
DOORS Next Generation. Before you begin, configure MATLAB for communication with
IBM Rational DOORS Next Generation by following the instructions in “Install the
Selection for Simulink Widget in IBM Rational DOORS Next Generation” on page 5-18.
Enable bidirectional requirements traceability with IBM Rational DOORS Next
Generation:

1 Select Analysis > > Requirements Traceability > > Settings in the
SimulinkEditor.

2 Switch to the Selection Linking tab and select DOORSin the Enabled
applications list.

Link to Requirements in IBM Rational DOORS Next Generation

To link and trace your Simulinkmodel elements to requirements in IBM Rational
DOORS Next Generation, use any of these workflows:

• “Link to Requirements by Using the Link Editor Dialog Box” on page 5-58
• “Link to Active Requirements in a Project by Using the Simulink Context Menu” on

page 5-59 if you have installed the Selection for Simulink widget in IBM Rational
DOORS Next Generation.

• “Link to the Requirements in a Project by Using the Numeric ID” on page 5-59 if you
have projects with many requirements.

Link to Requirements by Using the Link Editor Dialog Box

1 Right-click the Simulink model element to which you want to link IBM Rational
DOORS Next Generation requirements.

2 Select Requirements Traceability > > Open Link Editor.
3 In the Link Editor dialog box, click New and select OSLC Resource as the

Document type.
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4 Click Browse.
5 Enter your IBM Rational DOORS Next Generation login credentials. From the drop-

down list, select the active project name in IBM Rational DOORS Next Generation.
6 Switch to the Document Index tab and select the requirements that you want to

link to from the list of requirements. To create the link, click OK.

Link to Active Requirements in a Project by Using the Simulink Context Menu

Install the Selection for Simulink widget in IBM Rational DOORS Next Generation.
For more information, see Insert xref.

1 In IBM Rational DOORS Next Generation, open the Mini Dashboard and pin it to
the screen.

2 Switch to the Browse Artifacts view.
3 Select the requirements that you want to link to by selecting the check box next to

the requirement.

The requirements that you select for linking are displayed in the Selection for
Simulink widget in the Mini Dashboard.

4 Right-click the Simulink model element to which you want to link IBM Rational
DOORS Next Generation requirements.

5 Establish links to the requirements by selecting Requirements Traceability > >
Link to Current Item in DNG.

If you did not select any requirements in IBM Rational DOORS Next Generation
before attempting to establish links via the context menu in the Simulink Editor,
click List Projects in the dialog box that appears and select the requirements from
within IBM Rational DOORS Next Generation.

Link to the Requirements in a Project by Using the Numeric ID

1 Right-click the Simulink model to which you want to link IBM Rational DOORS
Next Generation requirements.

2 Select Requirements Traceability > > Link to Current Item in DNG.
3 Click Manual entry in the dialog box that appears and enter the numeric ID for the

link target. Establish links to the requirements by clicking OK.

If your RMI settings are configured for bidirectional linking, you see this dialog box.
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If you select Implemented By or Validated By, the target requirement in IBM
Rational DOORS Next Generation displays the new link to the Simulink model
element when you hover your cursor over it.

Navigate to Requirements from Simulink

Right-click the Simulink model element that requirements have been linked to. Select
Requirements Traceability. Navigate to the corresponding requirement in IBM
Rational DOORS Next Generation by clicking the naviagtion shortcut at the top of the
menu.
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External Storage
The first time you create links to requirements in a Simulink model, the RMI uses your
designated storage preference. When you reopen the model, the RMI loads the internally
stored links, or the links from the external file, as long as the file exists with the same
name and location as when you last saved the links.

The RMI allows you to save your links file as a different name or in a different folder.
However, when you start with the links file in a nondefault location, you must manually
load those links into the model. After you load those links, the RMI associates that model
with that file and loads the links automatically.

As you work with your model, the RMI stores links using the same storage as the
existing links. For example, if you open a model that has internally stored requirements
links, any new links you create are also stored internally. This is true even if your
preference is set to external storage.

All requirements links must be stored either with the model or in an external file. You
cannot mix internal and external storage within a given model.

To see an example of the external storage capability using a Simulink model, at the
MATLAB command line, enter:

slvnvdemo_powerwindow_external
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Guidelines for External Storage of Requirements Links
Follow these guidelines when storing requirements links in an external file.

• When sharing models, use the default name and location.

By default, external requirements are stored in a file named model_name.req in the
same folder as the model. If you give your model to others to review the requirements
traceability, give the reviewer both the model and .req files. That way, when you
load the model, the RMI automatically loads the links file.

• Do not rename the model outside of Simulink.

If you need to resave the model with a new name or in a different location, in the
model window, use File > Save As. Selecting this option causes the RMI to resave the
corresponding .req file using the model name and in the same location as the model.

• Be aware of unsaved requirements changes.

When you change a Simulink model, an asterisk appears next to the model name in
the title bar, indicating that the model has unsaved changes. If you are creating new
requirements links and storing them externally, this asterisk does not appear because
the model file itself has not changed. You can explicitly save the links, or, when you
close the model, the RMI prompts you to save the requirements links. When you save
the model, the RMI saves the links in the external file.
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Specify Storage for Requirements Links

Default Storage Mode for Traceability Data

By default, the Requirements Management Interface (RMI) stores requirements links in
a separate.req file. In the Requirements Settings dialog box, on the Storage tab, you
can enable internal storage or reenable external storage. This setting goes into effect
immediately and applies to all new models and to existing models with no links to
requirements.

If you open a model that already has requirements links, the RMI uses the storage
mechanism you used previously with that model, regardless of what your default storage
setting is.

To specify the requirements storage setting:

1 In the model window, select Analysis > Requirements Traceability > Settings.
2 In the Requirements Settings dialog box, select the Storage tab.
3 Under Default storage location for requirements links data:

• To enable internal storage, select Store internally (embedded in model file).
• To enable external storage, select Store externally (in a separate *.req file).

These settings go into effect immediately.

Duplicating outgoing links when copying Simulink and Stateflow objects

By default, the Requirements Management Interface (RMI) always duplicates
requirements links in copied Simulink and Stateflow objects. To only duplicate
requirements links when you highlight model requirements before copying objects, select
Duplicate links only when model requirements are highlighted.
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Save Requirements Links in External Storage
The Requirements Management Interface (RMI) stores externally stored requirements
links in a file whose name is based on the model file. Because of this, before you create
requirements links to be stored in an external file, you must save the model with a value
file name.

You add, modify, and delete requirements links in external storage the same way you do
when the requirements links are stored in the model file. The main difference is when
you change externally stored links, the model file does not change. The asterisk in the
title bar of the model window that indicates a model has unsaved changes does not
appear when you change requirements links. However, when you close the model, the
RMI asks if you want to save the requirements links modifications.

There are several ways to save requirements links that are stored in an external file, as
listed in the following table.
Select... To...
Analysis > Requirements Traceability
> Save Links As

Save the requirements links in an external
file using a file name that you specify. The
model itself is not saved.

Analysis > Requirements Traceability
> Save Links

Save the requirements links in an external
file using the default file name,
model_name.req, or to the previously
specified file. The model itself is not saved.

File > Save Save the current requirements links to an
external file named model_name.req, or
to the previously specified file. Any changes
you have made to the model are also saved.

File > Save As Rename and save the model and the
external requirements links. The external
file is saved as new_model_name.req.
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Load Requirements Links from External Storage
When you open a Simulink model that does not have internally stored requirements
links, the RMI tries to load requirements links from a .req file — either the default file
or a previously specified file. If that file does not exist, the RMI assumes that this model
has no requirements links.

To explicitly load requirements links from an external file:

1 Select Analysis > Requirements Traceability > Load Links.

The Select a file to load RMI data dialog box opens, with the default file name or the
previously used file name loaded into the File name field.

2 Select the file from which to load the requirements links.
3 Click Open to load the links from the selected file.

Caution If your model has unsaved changes to requirements links and you try to load
another file, a warning appears.
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Move Internally Stored Requirements Links to External Storage
If you have a model with requirements links that are stored with the model, you can
move those links to an external file. When you move internally stored links to a file, the
RMI deleted the internally stored links from the model file and saves the model. From
this point on, the data exists only in the external file.

1 Open the model that contains internally stored requirements links.
2 Select Analysis > Requirements Traceability > Move to File.

The Select a file to store RMI data dialog box prompts you to save the file with the
default name model_name.req.

3 Accept the default name, or enter a different file name if required.
4 Click Save.

Note Use the default name for externally stored requirements. For more information
about this recommendation, see “Guidelines for External Storage of Requirements
Links” on page 5-62.
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Move Externally Stored Requirements Links to the Model File
If you have a model with requirements links that are stored in an external file, you can
move those links to the model file.

1 Open the model that has only externally stored requirements links.
2 Make sure the right set of requirements links are loaded from the external file.
3 Select Analysis > Requirements Traceability > Copy to Model.

An asterisk appears next to the model name in the title bar of the model window
indicating that your model now has unsaved changes.

4 Save the model with the requirements links.

From this point on, the RMI stores all requirements links internally, in the model file.
When you add, modify, or delete links, the changes are stored with the model, even if the
Default storage location for requirements links data option is set to Store
externally (in a separate *.req file).
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Highlight Model Objects with Requirements
To review traceability in your model, you can highlight model objects that have
requirements links.

In this section...
“Highlight Model Objects with Requirements Using Model Editor” on page 5-68
“Highlight Model Objects with Requirements Using Model Explorer” on page 5-69

Highlight Model Objects with Requirements Using Model Editor

If you are working in the Simulink Editor and want to see which model objects in the
slvnvdemo_fuelsys_officereq model have requirements, follow these steps:

1 Open the example model:

slvnvdemo_fuelsys_officereq
2 Select Analysis > Requirements Traceability > Highlight Model.

Two types of highlighting indicate model objects with requirements:

• Yellow highlighting indicates objects that have requirements links for the object
itself.

• Orange outline indicates objects, such as subsystems, whose child objects have
requirements links.
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Objects that do not have requirements are colored gray.

3 To remove the highlighting from the model, select Analysis > Requirements
Traceability > Unhighlight Model. Alternatively, you can right-click anywhere in
the model, and select Remove Highlighting.

While a model is highlighted, you can still manage the model and its contents.

Highlight Model Objects with Requirements Using Model Explorer
If you are working in Model Explorer and want to see which model objects have
requirements, follow these steps:

1 Open the example model:
slvnvdemo_fuelsys_officereq
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2 Select View > Model Explorer.
3 To highlight all model objects with requirements, click the Highlight items with

requirements on model icon ( ).

The Simulink Editor window opens, and all objects in the model with requirements
are highlighted.

Note If you are running a 64-bit version of MATLAB, when you navigate to a
requirement in a PDF file, the file opens at the beginning of the document, not at the
specified location.
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Navigate to Requirements from Model

In this section...
“Navigate from Model Object” on page 5-71
“Navigate from System Requirements Block” on page 5-71

Navigate from Model Object

You can navigate directly from a model object to that object's associated requirement.
When you take these steps, the external requirements document opens in the
application, with the requirements text highlighted.

1 Open the example model:

slvnvdemo_fuelsys_officereq
2 Open the fuel rate controller subsystem.
3 To open the linked requirement, right-click the Airflow calculation subsystem and

select Requirements Traceability > 1. “Mass airflow estimation”.

The Microsoft Word document slvnvdemo_FuelSys_DesignDescription.docx,
opens with the section 2.1 Mass airflow estimation selected.

Note If you are running a 64-bit version of MATLAB, when you navigate to a
requirement in a PDF file, the file opens at the top of the page, not at the bookmark
location.

Navigate from System Requirements Block

Sometimes you want to see all the requirements links at a given level of the model
hierarchy. In such cases, you can insert a System Requirements block to collect all
requirements links in a model or subsystem. The System Requirements block lists
requirements links for the model or subsystem in which it resides; it does not list
requirements links for model objects inside that model or subsystem, because those are
at a different level of the model hierarchy.
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In the following example, you insert a System Requirements block at the top level of the
slvnvdemo_fuelsys_officereq model, and navigate to the requirements using the
links inside the block.

1 Open the example model:

slvnvdemo_fuelsys_officereq
2 In the Simulink Editor, select Analysis > Requirements Traceability >

Highlight Model.
3 Open the fuel rate controller subsystem.

The Airflow calculation subsystem has a requirements link.
4 Open the Airflow calculation subsystem.
5 In the Simulink Editor, select View > Library Browser.
6 On the Libraries pane, select Simulink Requirements.

This library contains only one block—the System Requirements block.
7 Drag a System Requirements block into the Airflow calculation subsystem.

The RMI software collects and displays any requirements links for that subsystem in
the System Requirements block.

8 In the System Requirements block, double-click 1. “Mass airflow subsystem”.

The Microsoft Word document, slvnvdemo_FuelSys_DesignDescription.docx,
opens, with the section 2.1 Mass airflow estimation selected.
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Customize Requirements Traceability Report for Model
In this section...
“Create Default Requirements Report” on page 5-73
“Report for Requirements in Model Blocks” on page 5-81
“Customize Requirements Report” on page 5-83
“Generate Requirements Reports Using Simulink” on page 5-88

Create Default Requirements Report
If you have a model that contains links to external requirements documents, you can
create an HTML report that contains summarized and detailed information about those
links. In addition, the report contains links that allow you to navigate to both the model
and to the requirements documents.

You can generate a default report with information about all the requirements associated
with a model and its objects.

Note If the model for which you are creating a report contains Model blocks, see “Report
for Requirements in Model Blocks” on page 5-81.

Before you generate the report, add a requirement to a Stateflow chart to see information
that the requirements report contains about Stateflow charts:

1 Open the example model:
slvnvdemo_fuelsys_officereq

2 Open the fuel rate controller subsystem.
3 Open the Microsoft Word requirements document:

matlabroot/toolbox/slvnv/rmidemos/fuelsys_req_docs/...
    slvnvdemo_FuelSys_RequirementsSpecification.docx

4 Create a link from the control logic Stateflow chart to a location in this document.
5 Keep the example model open, but close the requirements document.

To generate a default requirements report for the slvnvdemo_fuelsys_officereq
model:
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1 Select Analysis > Requirements Traceability > Generate Report.

The Requirements Management Interface (RMI) searches through all the blocks and
subsystems in the model for associated requirements. The RMI generates and displays a
complete report in HTML format.

The report is saved with the default name, model_name_requirements.html. If you
generate a subsequent report on the same model, the new report file overwrites any
earlier report file.

The report contains the following content:

• “Table of Contents” on page 5-74
• “List of Tables” on page 5-75
• “Model Information” on page 5-76
• “Documents Summary” on page 5-76
• “System” on page 5-77
• “Chart” on page 5-80

Table of Contents

The Table of Contents lists the major sections of the report. There is one System
section for the top-level model and one System section for each subsystem, Model block,
or Stateflow chart.

Click a link to view information about a specific section of the model.
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List of Tables

The List of Tables includes links to each table in the report.
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Model Information

The Model Information contains general information about the model, such as when
the model was created and when the model was last modified.

Documents Summary

The Documents Summary section lists all the requirements documents to which
objects in the slvnvdemo_fuelsys_officereq model link, along with some additional
information about each document.
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• ID — The ID. In this example, DOC1, DOC2, DOC3, and DOC4 are short names for
the requirements documents linked from this model.

Before you generate a report, in the Settings dialog box, on the Reports tab, if you
select User document IDs in requirements tables, links with these short names
are included throughout the report when referring to a requirements document. When
you click a short name link in a report, the requirements document associated with
that document ID opens.

When your requirements documents have long path names that can clutter the
report, select the User document IDs in requirements tables option. This option
is disabled by default, as you can see in the examples in this section.

• Document paths stored in the model — Click this link to open the requirements
document in its native application.

• Last modified — The date the requirements document was last modified.
• # links — The total number of links to a requirements document.

System

Each System section includes:

• An image of the model or model object. The objects with requirements are highlighted.
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• A list of requirements associated with the model or model object. In this example,
click the target document name to open the requirements document associated with
the slvnvdemo_fuelsys_officereq model.

• A list of blocks in the top-level model that have requirements. In this example, only
the MAP sensor block has a requirement at the top level. Click the link next to
Target: to open the requirements document associated with the MAP sensor block.
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The preceding table does not include these blocks in the top-level model because:

• The fuel rate controller and engine gas dynamics subsystems are in dedicated
chapters of the report.

• The report lists Signal Builder blocks separately, in this example, in Table 3.3.
• A list of requirements associated with each signal group in any Signal Builder block,

and a graphic of that signal group. In this example, the Test inputs Signal Builder
block in the top-level model has one signal group that has a requirement link. Click
the link under Target (document name and location ID) to open the
requirements document associated with this signal group in the Test inputs block.
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Chart

Each Chart section reports on requirements in Stateflow charts, and includes:

• A graphic of the Stateflow chart that identifies each state.
• A list of elements that have requirements.

To navigate to the requirements document associated with a chart element, click the
link next to Target.
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Report for Requirements in Model Blocks

If your model contains Model blocks that reference external models, the default report
does not include information about requirements in the referenced models. To generate a
report that includes requirements information for referenced models, you must have a
license for the Simulink Report Generator™ software. The report includes the same
information and graphics for referenced models as it does for the top-level model.

If you have a Simulink Report Generator license, before generating a requirements
report, take the following steps:

1 Open the model for which you want to create a requirements report. This workflow
uses the example model slvnvdemo_fuelsys_officereq.

2 To open the template for the default requirements report, at the MATLAB command
prompt, enter:

setedit requirements
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3 In the Simulink Report Generator software window, in the far-left pane, click the
Model Loop component.

4 On the far-right pane, locate the Model reference field. If you cannot see the drop-
down arrow for that field, expand the pane.

5 In the Model reference field drop-down list, select Follow all model
reference blocks.

6 To generate a requirements report for the open model that includes information
about referenced models, click the Report icon .
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Customize Requirements Report
The Requirements Management Interface (RMI) uses the Simulink Report Generator
software to generate the requirements report. You can customize the requirements report
using the RMI or the Simulink Report Generator software:

• “Customize Requirements Report Using the RMI Settings” on page 5-83
• “Customize Requirements Report Using Simulink Report Generator” on page 5-86

Customize Requirements Report Using the RMI Settings

There are several options for customizing a requirements report using the Requirements
Settings dialog box.
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On the Report tab, select options that specify the contents that you want in the report.
Requirements Settings Report Option Description
Highlight the model before generating
report

Enables highlighting of Simulink objects
with requirements in the report graphics.

Include links in referenced libraries
and data dictionaries

Includes requirements links in referenced
libraries in the generated report.

Report objects with no links to
requirements

Includes lists of model objects that have no
requirements.

Show user tags for each reported link Lists the user tags, if any, for each reported
link.

Use document IDs in requirements
tables

Uses a document ID, if available, instead of
a path name in the tables of the
requirements report. This capability
prevents long path names to requirements
documents from cluttering the report
tables.

Include details from linked documents Includes additional content from linked
requirements. The following requirements
documents are supported:

• Microsoft Word
• Microsoft Excel
• IBMRationalDOORS

Include links to Simulink objects Includes links from the report to objects in
Simulink.

Use internal HTTP server to support
navigation from system browsers

Specifies use of internal MATLAB HTTP
server for navigation from generated report
to documents and model objects. By
selecting this setting, this navigation is
available from system browsers as long as
the MATLAB internal HTTP server is
active on your local host. To start the
internal HTTP server, at the MATLAB
command prompt, type rmi('httpLink').

To see how these options affect the content of the report:
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1 Open the slvnvdemo_fuelsys_officereq model:

slvnvdemo_fuelsys_officereq
2 In the model window, select Analysis > Requirements Traceability > Settings.
3 In the Requirements Settings dialog box, click the Report tab.
4 For this example, select Highlight the model before generating report.

When you select this option, before generating the report, the graphics of the model
that are included in the report are highlighted so that you can easily see which
objects have requirements.

5 To close the Requirements Settings dialog box, click Close.
6 Generate a requirements report by selecting Analysis > Requirements

Traceability > Generate Report.

The requirements report opens in a browser window so that you can review the
content of the report.

7 If you do not want to overwrite the current report when you regenerate the
requirements report, rename the HTML file, for example,
slvnvdemo_fuelsys_officereq_requirements_old.html.

The default report file name is model_name_requirements.html.
8 In the model window, select Analysis > Requirements Traceability > Settings.
9 On the Report tab, select:

• Show user tags for each reported link — The report lists the user tags (if
any) associated with each requirement.

• Include details from linked documents — The report includes additional
details for requirements in the following types of requirements documents.
Requirements Document Format Includes in the Report
Microsoft Word Full text of the paragraph or subsection of the

requirement, including tables.
Microsoft Excel If the target requirement is a group of cells,

the report includes all those cells as a table. If
the target requirement is one cell, the report
includes that cell and all the cells in that row
to the right of the target cell.
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Requirements Document Format Includes in the Report
IBMRationalDOORS By default, the report includes:

• DOORS Object Heading
• DOORS Object Text
• All other attributes except Created Thru,

attributes with empty string values, and
system attributes that are false.

Use the RptgenRMI.doorsAttribs function
to include or exclude specific attributes or
groups of attributes.

10 Close the Requirements Settings dialog box.
11 Generate a new requirements report by selecting Analysis > Requirements

Traceability > Generate Report.
12 Compare this new report to the report that you renamed in step 7:

• User tags associated with requirements links are included.
• Details from the requirement content are included as specified in step 9.

13 When you are done reviewing the report, close the report and the model.

To see an example of including details in the requirements report, enter the following
command at the MATLAB command prompt:

slvnvdemo_powerwindow_report

Customize Requirements Report Using Simulink Report Generator

If you have a license for the Simulink Report Generator software, you can further modify
the default requirements report.

At the MATLAB command prompt, enter the following command:

setedit requirements

The Report Explorer GUI opens the requirements report template that the RMI uses
when generating a requirements report. The report template contains Simulink Report
Generator components that define the structure of the requirements report.
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If you click a component in the middle pane, the options that you can specify for that
component appear in the right-hand pane. For detailed information about using a
particular component to customize your report, click Help at the bottom of the right-
hand pane.

In addition to the standard report components, Simulink Report Generator provides
components specific to the RMI in the Requirements Management Interface category.
Simulink Report Generator Component Report Information
Missing Requirements Block Loop Applies all child components to blocks that

have no requirements
Missing Requirements System Loop Applies all child components to systems

that have no requirements
Requirements Block Loop Applies all child components to blocks that

have requirements
Requirements Documents Table Inserts a table that lists requirements

documents
Requirements Signal Loop Applies all child components to signal

groups with requirements
Requirements Summary Table Inserts a property table that lists

requirements information for blocks with
associated requirements

Requirements System Loop Applies all child components to systems
with requirements

Requirements Table Inserts a table that lists system and
subsystem requirements

Data Dictionary Traceability
Table

Inserts a table that links data dictionary
information to requirements

MATLAB Code Traceability Table Inserts a table that links MATLAB code to
requirements

Simulink Test Suite Traceability
Table

Inserts a table that links a Simulink test
suite to requirements

To customize the requirements report, you can:

• Add or delete components.
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• Move components up or down in the report hierarchy.
• Customize components to specify how the report presents certain information.

For more information, see the Simulink Report Generator documentation.

Generate Requirements Reports Using Simulink

When you have a model open in Simulink, the Model Editor provides two options for
creating requirements reports:

• “System Design Description Report” on page 5-88
• “Design Requirements Report” on page 5-89

System Design Description Report

The System Design Description report describes a system design represented by the
current Simulink model.

You can use the System Design Description report to:

• Review a system design without having the model open.
• Generate summary and detailed descriptions of the design.
• Assess compliance with design requirements.
• Archive the system design in a format independent of the modeling environment.
• Build a customized version of the report using the Simulink Report Generator

software.

To generate a System Design Description report that includes requirements information:

1 Open the model for which you want to create a report.
2 Select File > Reports > System Design Description.
3 In the Design Description dialog box, select Requirements traceability.
4 Select any other options that you want for this report.
5 Click Generate.

As the software is generating the report, the status appears in the MATLAB
command window.
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The report name is the model name, followed by a numeral, followed by the extension
that reflects the document type (.pdf, .html, etc.).

If your model has linked requirements, the report includes a chapter, Requirements
Traceability, that includes:

• Lists of model objects that have requirements with hyperlinks to display the objects
• Images of each subsystem, highlighting model objects with requirements

Design Requirements Report

In the Simulink Editor, the menu option File > Reports > System Requirements
creates a requirements report, as described in “Create Default Requirements Report” on
page 5-73. This menu option is equivalent to Analysis > Requirements Traceability >
Generate Report.

To specify options for the report, select Analysis > Requirements Traceability >
Settings. Before generating the report, on the Report tab, set the options that you
want. For detailed information about these options, see “Customize Requirements
Report” on page 5-83.

 Customize Requirements Traceability Report for Model

5-89



Filter Requirements with User Tags

In this section...
“User Tags and Requirements Filtering” on page 5-90
“Apply a User Tag to a Requirement” on page 5-90
“Filter, Highlight, and Report with User Tags” on page 5-92
“Apply User Tags During Selection-Based Linking” on page 5-93
“Configure Requirements Filtering” on page 5-95

User Tags and Requirements Filtering

User tags are user-defined keywords that you associate with specific requirements. With
user tags, you can highlight a model or generate a requirements report for a model in the
following ways:

• Highlight or report only those requirements that have a specific user tag.
• Highlight or report only those requirements that have one of several user tags.
• Do not highlight and report requirements that have a specific user tag.

Apply a User Tag to a Requirement

To apply one or more user tags to a newly created requirement:

1 Open the example model:

slvnvdemo_fuelsys_officereq
2 Open the fuel rate controller subsystem.
3 To open the requirements document, right-click the Airflow calculation subsystem

and select Requirements Traceability > Open Link Editor.

The Requirements Traceability Link Editor opens with the details about the
requirement that you created.
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4 In the User tag field, enter one or more keywords, separated by commas, that the
RMI can use to filter requirements. In this example, after design, enter a comma,
followed by the user tag test to specify a second user tag for this requirement.

User tags:

• Are not case sensitive.
• Can consist of multiple words. For example, if you enter design requirement,

the entire phrase constitutes the user tag. Separate user tags with commas.
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5 Click Apply or OK to save the changes.

Filter, Highlight, and Report with User Tags
The slvnvdemo_fuelsys_officereq model includes several requirements with the
user tag design. This section describes how to highlight only those model objects that
have the user tag, test.

1 In the Simulink Editor, remove highlighting from the
slvnvdemo_fuelsys_officereq model by selecting Analysis > Requirements
Traceability > Unhighlight model.

2 Select Analysis > Requirements Traceability > Settings.
3 In the Requirements Settings dialog box, click the Filters tab.
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4 To enable filtering with user tags, click the Filter links by user tags when
highlighting and reporting requirements option.

5 To include only those requirements that have the user tag, test, enter test in the
Include links with any of these tags field.

6 Click Close.
7 In the Simulink Editor, select Analysis > Requirements Traceability >

Highlight model.

The RMI highlights only those model objects whose requirements have the user tag
test, for example, the MAP sensor.

8 Reopen the Requirements Settings dialog box to the Filters tab.
9 In the Include links with any of these tags field, delete test. In the Exclude

links with any of these tags field, add test.

In the model, the highlighting changes to exclude objects whose requirements have
the test user tag. The MAP sensor and Test inputs blocks are no longer highlighted.

10 In the Simulink Editor, select Analysis > Requirements Traceability >
Generate Report.

The report does not include information about objects whose requirements have the
test user tag.

Apply User Tags During Selection-Based Linking

When creating a succession of requirements links, you can apply the same user tags to
all links automatically. This capability, also known as selection-based linking, is
available only when you are creating links to selected objects in the requirements
documents.

When creating selection-based links, specify one or more user tags to apply to
requirements:

1 In the Simulink Editor, select Analysis > Requirements Traceability > Settings.
2 Select the Selection Linking tab.
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3 In the Apply this user tag to new links field, enter one or more user tags,
separated by commas.

The RMI applies these user tags to all new selection-based requirements links that
you create.

4 Click Close to close the Requirements Settings dialog box.
5 In a requirements document, select the specific requirement text.
6 Right-click a model object and select Requirements Traceability.

The selection-based linking options specify which user tags the RMI applies to the
link that you create. In the following example, you can apply the user tags design,
general, and reqtslink to the link that you create to your selected text.
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Configure Requirements Filtering

In the Requirements Settings dialog box, in the Filters tab, use the following options for
filtering requirements in a model.
Option Description
Filter links by user tags when
highlighting and reporting
requirements

Enables filtering for highlighting and
reporting, based on specified user tags.

Include links with any of these tags Includes information about all
requirements that have any of the specified
user tags. Separate multiple user tags with
commas.

Exclude links with any of these tags Excludes information about all
requirements that have any of the specified
user tags. Separate multiple user tags with
commas or spaces.

Apply same filters in context menus Disables link labels in context menus if any
of the specified filters are satisfied, for
example, if a requirement has a designated
user tag.
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Option Description
Apply same filters in consistency
checking

Includes or excludes requirements with
specified user tags when running a
consistency check between a model and its
associated requirements documents.

Under Link type filters, Disable
DOORS surrogate item links in
context menus

Disables links to IBM Rational DOORS
surrogate items from the context menus
when you right-click a model object. This
option does not depend on current user tag
filters.
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Create Requirements Traceability Report for Simulink Project
To create a report for requirements traceability data in a Simulink Project:

1 Open your Simulink Project.
2 At the MATLAB command prompt, enter the following:

rmi('projectreport')

The MATLAB Web browser opens, showing the traceability report for the Simulink
Project.

This top-level HTML report contains a separate section for Simulink model files,
MATLAB code files, and other files included in the project. For each individual file with
one or more associated requirements links, a separate HTML report, or sub-report,
shows the requirements traceability data for that file. The top-level report contains links
to each sub-report.

If you have a MATLAB file with requirements traceability links that is not part of a
Simulink Project, you can create a separate report for the MATLAB file using the
rmi('report', matlabfilepath) command. For more information, see rmi.
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View Requirements Details for a Selected Block

In this section...
“Requirements Details Workflow” on page 5-98
“Requirements Details Limitations” on page 5-99

Requirements Details Workflow

When you highlight model objects with requirements, you can view the requirements
details for a selected block. Follow this workflow:

1 From the menu bar, select Analysis > Requirements Traceability > Highlight
Model.

2 In your model, highlights indicate model objects with requirements links.

3 In the requirements details window, click the link to load the requirements details.

If your Simulink model has links to Microsoft Word, Microsoft Excel, or IBM
Rational DOORS documents, the requirements management interface loads
requirements context from the documents and additional link labels stored by
Simulink.

4 Select highlighted model objects to display associated RMI links in the requirements
details window.

5 Close the requirements details window to remove highlights from the Simulink
model.

For more information see “Navigate to Requirements from Model” on page 5-71.
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Requirements Details Limitations

Security restrictions in Microsoft Office can interrupt the requirements details loading
process. Requirement details loaded from read-only Microsoft Office documents,
documents stored on network drives, and documents with Microsoft Office Trust Center
ActiveX control restrictions may not work with RMI. Consider enabling ActiveX controls
without prompting and using requirements stored in a writable location on the MATLAB
path.

Before loading requirements details for IBM Rational DOORS links, you must be logged
in to the IBM Rational DOORS Client.
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Validation of Requirements Links
Requirements links in a model can become outdated when requirements change over
time. Similarly, links in requirements documents may become invalid when your
Simulink model changes, for example, when the model, or objects in the model, are
renamed, moved, or deleted. The Simulink Requirements software provides tools that
allow you to detect and resolve these problems in the model or in the requirements
document.

In this section...
“When to Check Links in a Requirements Document” on page 5-100
“How the rmi Function Checks a Requirements Document” on page 5-101

When to Check Links in a Requirements Document

When you enable Modify destination for bidirectional linking and create a link
between a requirement and a Simulink model object, the RMI software inserts a
navigation control into your requirements document. These links may become invalid if
your model changes.

To check these links, the 'checkDoc' option of the rmi function reviews a requirements
document to verify that all the navigation controls represent valid links to model objects.
The checkDoc command can check the following types of requirements documents:

• Microsoft Word
• Microsoft Excel
• IBM Rational DOORS

The rmi function only checks requirements documents that contain navigation controls;
to check links in your Simulink model, see “Validate Requirements Links in a Model” on
page 5-102.

Note For more information about inserting navigation controls in requirements
documents, see:

• “Insert Navigation Objects in Microsoft Office Requirements Documents” on page 5-
156
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• “Insert Navigation Objects into DOORS Requirements” on page 5-147

How the rmi Function Checks a Requirements Document

rmi performs the following actions:

• Locates all links to Simulink objects in the specified requirements document.
• Checks each link to verify that the target object is present in a Simulink model. If the

target object is present, rmi checks that the link label matches the target object.
• Modifies the navigation controls in the requirements document to identify any

detected problems. This allows you to see invalid links at a glance:

• Valid link: 
• Invalid link: 
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Validate Requirements Links in a Model
In this section...
“Check Requirements Links with the Model Advisor” on page 5-102
“Fix Invalid Requirements Links Detected by the Model Advisor” on page 5-105

Check Requirements Links with the Model Advisor

To make sure that every requirements link in your Simulink model has a valid target in
a requirements document, run the Model Advisor Requirements consistency checks:

1 Open the example model:

slvnvdemo_fuelsys_officereq
2 Open the Model Advisor to run a consistency check by selecting Analysis >

Requirements Traceability > Check Consistency.

In the Requirements Consistency Checking category, all the checks are selected.
For this tutorial, keep all the checks selected.

These checks identify the following problems with your model requirements.
Consistency Check Problem Identified
Identify requirement links with missing
documents

The Model Advisor cannot find the requirements
document. This might indicate a problem with
the path to the requirements document.
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Consistency Check Problem Identified
Identify requirement links that specify
invalid locations within documents

The Model Advisor cannot find the designated
location for the requirement. This check is
implemented for:

• Microsoft Word documents
• Microsoft Excel documents
• IBM Rational DOORS documents
• Simulink objects

Identify selection-based links having
description fields that do not match their
requirements document text

The Description field for the link does not
match the requirements document text. When
you create selection-based links, the
Requirements Management Interface (RMI)
saves the selected text in the link Description
field. This check is implemented for:

• Microsoft Word documents
• Microsoft Excel documents
• IBM Rational DOORS documents
• Simulink objects

Identify requirement links with path type
inconsistent with preferences

The path to the requirements document does not
match the Document file reference field in
the Requirements Settings dialog box Selection
Linking tab. This might indicate a problem
with the path to the requirements document.

On Linux systems, this check is named Identify
requirement links with absolute path type.
The check reports a warning for each
requirements links that uses an absolute path.

Note For information about how the RMI
resolves the path to the requirements document,
see “Document Path Storage” on page 5-113.
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The Model Advisor checks to see if any applications that have link targets are
running:

• If your model has links to Microsoft Word or Microsoft Excel documents, the
consistency check requires that you close all instances of those applications. If
you have one of these applications open, it displays a warning and does not
continue the checks. The consistency checks must verify up-to-date stored copies
of the requirements documents.

• If your model has links to DOORS requirements, you must be logged in to the
DOORS software. Your DOORS database must include the module that contains
the target requirements.

3 For this tutorial, make sure that you close both Microsoft Word and Microsoft Excel.
4 Click Run Selected Checks.

After the check is complete:

• The green circles with the check mark indicate that two checks passed.
• The yellow triangles with the exclamation point indicate that two checks

generated warnings.

The right-hand pane shows that two checks passed and two checks had warnings.
The Report box includes a link to the HTML report.

Keep the Model Advisor open. The next section describes how to interpret and fix the
inconsistent links.

Note To step through an example that uses the Model Advisor to check requirements
links in an IBM Rational DOORS database, run the Managing Requirements for Fault-
Tolerant Fuel Control System (IBM Rational DOORS) example in the MATLAB
command prompt.
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Fix Invalid Requirements Links Detected by the Model Advisor

In “Check Requirements Links with the Model Advisor” on page 5-102, three
requirements consistency checks generate warnings in the
slvnvdemo_fuelsys_officereq model.

Resolve Warning: Identify requirement links that specify invalid locations within documents

To fix the warning about attempting to link to an invalid location in a requirements
document:

1 In the Model Advisor, select Identify requirement links that specify invalid
locations within documents to display the description of the warning.

This check identifies a link that specifies a location that does not exist in the
Microsoft Word requirements document,
slvnvdemo_FuelSys_DesignDescription.docx. The link originates in the
Terminator1 block. In this example, the target location in the requirements
document was deleted after the requirement was created.

2 Get more information about this link:

a To navigate to the Terminator1 block, under Block, click the hyperlink.
b To open the “Requirements Traceability Link Editor” on page 5-20 for this link,

under Requirements, click the hyperlink.
3 To fix the problem from the Requirements Traceability Link Editor, do one of the

following:
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• In the Location field, specify a valid location in the requirements document.
• Delete the requirements link by selecting the link and clicking Delete.

4 In the Model Advisor, select the Requirements Consistency Checking category of
checks.

5 Click Run Selected Checks again, and verify that the warning no longer occurs.

Resolve Warning: Identify selection-based links having description fields that do not match
their requirements document text

To fix the warnings about the Description field not matching the requirements
document text:

1 In the Model Advisor, click Identify selection-based links having description
fields that do not match their requirements document text to display the
description of the warning.
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The first message indicated that the model contains a link to a bookmark named
Simulink_requirement_item_7 in the requirements document that does not exist.

In addition, this check identified the following mismatching text between the
requirements blocks and the requirements document:

• The Description field in the Test inputs Signal Builder block link is Normal
mode of operation. The requirement text is The simulation is run with a
throttle input that ramps from 10 to 20 degrees over a period of two
seconds, then back to 10 degrees over the next two seconds. This cycle
repeats continuously while the engine is held at a constant speed.
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• The Description field in the MAP Estimate block link is Manifold pressure
failure. The requirement text in
slvnvdemo_FuelSys_DesignDescription.docx is Manifold pressure
failure mode.

2 Get more information about this link:

a To navigate to a block, under Block, click the hyperlink.
b To open the “Requirements Traceability Link Editor” on page 5-20 for this link,

under Current Description, click the hyperlink.
3 Fix this problem in one of two ways:

• In the Model Advisor, click Update. This action automatically updates the
Description field for that link so that it matches the requirement.

• In the Link Editor, manually edit the link from the block so that the
Description field matches the selected requirements text.

4 In the Model Advisor, select the Requirements Consistency Checking category of
checks.

5 Click Run Selected Checks again, and verify that the warning no longer occurs.
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Validate Requirements Links in a Requirements Document

In this section...
“Check Links in a Requirements Document” on page 5-109
“When Multiple Objects Have Links to the Same Requirement” on page 5-110
“Fix Invalid Links in a Requirements Document” on page 5-111

Check Links in a Requirements Document

To check the links in a requirements document:

1 At the MATLAB command prompt, enter

rmi('checkdoc', docName)

docName is a character vector that represents one of the following:

• Module ID for a DOORS requirements document
• Full path name for a Microsoft Word requirements document
• Full path name for a Microsoft Excel requirements document

The rmi function creates and displays an HTML report that lists all requirements
links in the document.

The report highlights invalid links in red. For each invalid link, the report includes
brief details about the problem and a hyperlink to the invalid link in the
requirements document. The report groups together links that have the same
problem.

2 Double-click the hyperlink under Document content to open the requirements
document at the invalid link.

The navigation controls for the invalid link has a different appearance than the
navigation controls for the valid links.

3 When there are invalid links in your requirements document, you have the following
options:
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If you want to... Do the following...
Fix the invalid links Follow the instructions in “Fix Invalid

Links in a Requirements Document” on
page 5-111.

Keep the changes to the navigation
controls without fixing the invalid links

Save the requirements document.

Ignore the invalid links Close the requirements document
without saving it.

When Multiple Objects Have Links to the Same Requirement

When you link multiple objects to the same requirement, as described in “Link Multiple
Model Objects to a Requirements Document” on page 5-28, only one navigation object is
inserted into the requirements document. When you double-click that navigation object,
all of the linked model objects are highlighted.

If you check the requirements document using the 'checkdoc' option of the rmi
function and the check detects a navigation object that points to multiple objects, the
check stops and displays the following dialog box.

You have two options:

• If you click Yes, or you close this dialog box, the RMI creates additional navigation
objects, one for each model object that links to that requirement. The document check
continues, but the RMI does not recheck that navigation; the report only shows one
link for that requirement. To rerun the check so that all requirements are checked, at
the top of the report, click Refresh.
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• If you click No, the document check continues, and the report identifies that
navigation object as a broken link.

Fix Invalid Links in a Requirements Document

Using the report that the rmi function creates, you may be able to fix the invalid links in
your requirements document.

In the following example, rmi cannot locate the model specified in two links.

To fix invalid links:

1 In the report, under Document content, click the hyperlink associated with the
invalid requirement link.

The requirements document opens with the requirement text highlighted.
2 In the requirements document, depending on the document format, take these steps:

• In DOORS:

a Select the navigation control for an invalid link.
b Select MATLAB > Select item.

• In Microsoft Word, double-click the navigation control.

A dialog box opens that allows you to fix, reset, or ignore all the invalid links with a
given problem.

3 Click one of the following options.

 Validate Requirements Links in a Requirements Document

5-111



To... Click...
Navigate to and select a new target model or new
target objects for these broken links.

Fix all

Reset the navigation controls for these invalid links
to their original state, the state before you checked
the requirements document.

Reset all

Make no changes to the requirements document.
Any modifications rmi made to the navigation
controls remain in the requirements document.

Cancel

4 Save the requirements document to preserve the changes made by the rmi function.
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Document Path Storage
When you create a requirements link, the RMI stores the location of the requirements
document with the link. If you use selection-based linking or browse to select a
requirements document, the RMI stores the document location as specified by the
Document file reference option on the Requirements Settings dialog box, Selection
Linking tab. The available settings are:

• Absolute path
• Path relative to current folder
• Path relative to model folder
• Filename only (on MATLAB path)

You can also manually enter an absolute or relative path for the document location. A
relative path can be a partial path or no path at all, but you must specify the file name of
the requirements document. If you use a relative path, the document is not constrained
to a single location in the file system. With a relative path, the RMI resolves the exact
location of the requirements document in this order:

1 The software attempts to resolve the path relative to the current MATLAB folder.
2 When there is no path specification and the document is not in the current folder,

the software uses the MATLAB search path to locate the file.
3 If the RMI cannot locate the document relative to the current folder or the MATLAB

search path, the RMI resolves the path relative to the model file folder.

The following examples illustrate the procedure for locating a requirements document.

Relative (Partial) Path Example
Current MATLAB folder C:\work\scratch
Model file C:\work\models\controllers\pid.mdl
Document link ..\reqs\pid.html
Documents searched for
(in order)

C:\work\reqs\pid.html
C:\work\models\reqs\pid.html
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Relative (No) Path Example
Current MATLAB folder C:\work\scratch
Model file C:\work\models\controllers\pid.mdl
Requirements document pid.html
Documents searched for
(in order)

C:\work\scratch\pid.html
<MATLAB path dir>\pid.html
C:\work\models\controllers\pid.html

Absolute Path Example
Current MATLAB folder C:\work\scratch
Model file C:\work\models\controllers\pid.mdl
Requirements document C:\work\reqs\pid.html
Documents searched for C:\work\reqs\pid.html

5 Requirements Management Interface

5-114



Delete Requirements Links from Simulink Objects

In this section...
“Delete a Single Link from a Simulink Object” on page 5-115
“Delete All Links from a Simulink Object” on page 5-115
“Delete All Links from Multiple Simulink Objects” on page 5-116

Delete a Single Link from a Simulink Object

If you have an obsolete link to a requirement, delete it from the model object.

To delete a single link to a requirement from a Simulink model object:

1 Right-click a model object and select Requirements Traceability > Open Link
Editor.

2 In the top-most pane of the Link Editor, select the link that you want to delete.
3 Click Delete.
4 Click Apply or OK to complete the deletion.

Delete All Links from a Simulink Object

To delete all links to requirements from a Simulink model object:

1 Right-click the model object and select Requirements Traceability > Delete All
Links

2 Click OK to confirm the deletion.

This action deletes all requirements at the top level of the object. For example, if you
delete requirements for a subsystem, this action does not delete any requirements
for objects inside the subsystem; it only deletes requirements for the subsystem
itself. To delete requirements for child objects inside a subsystem, Model block, or
Stateflow chart, you must navigate to each child object and perform these steps for
each object from which you want to delete requirements.
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Delete All Links from Multiple Simulink Objects

To delete all requirements links from a group of Simulink model objects in the same
model diagram or Stateflow chart:

1 Select the model objects whose requirements links you want to delete.
2 Right-click one of the objects and select Requirements Traceability > Delete All.
3 Click OK to confirm the deletion.

This action deletes all requirements at the top level of each object. It does not delete
requirements for child objects inside subsystems, Model blocks, or Stateflow charts.
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Requirements Links for Library Blocks and Reference Blocks

In this section...
“Introduction to Library Blocks and Reference Blocks” on page 5-117
“Library Blocks and Requirements” on page 5-117
“Copy Library Blocks with Requirements” on page 5-118
“Manage Requirements on Reference Blocks” on page 5-118
“Manage Requirements Inside Reference Blocks” on page 5-119
“Links from Requirements to Library Blocks” on page 5-122

Introduction to Library Blocks and Reference Blocks

Simulink allows you to create your own block libraries. If you create a block library, you
can reuse the functionality of a block, subsystem, or Stateflow atomic subchart in
multiple models.

When you copy a library block to a Simulink model, the new block is called a reference
block. You can create several instances of this library block in one or more models.

The reference block is linked to the library block using a library link. If you change a
library block, any reference block that is linked to the library block is updated with those
changes when you open or update the model that contains the reference block.

Note For more information about reference blocks and library links, see “Libraries”
(Simulink).

Library Blocks and Requirements

Library blocks themselves can have links to requirements. In addition, if a library block
is a subsystem or atomic subchart, the objects inside the library blocks can have library
links. You use the Requirements Management Interface (RMI) to create and manage
requirements links in libraries and in models.

The following sections describe how to manage requirements links on and inside library
blocks and reference blocks.
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Copy Library Blocks with Requirements

When you copy a library subsystem or masked block to a model, you can highlight, view
and navigate requirements links on the library block and on objects inside the library
block. However, those links are not associated with that model. The links are stored with
the library, not with the model.

You cannot add, modify, or delete requirements links on the library block from the
context of the reference block. If you disable the link from the reference block to the
library block, you can modify requirements on objects that are inside library blocks just
as you can for other block attributes when a library link has been disabled.

Manage Requirements on Reference Blocks

You use the RMI to manage requirements links on a reference block just like any other
model object. You can view and navigate both local and library requirements on a
reference block.

For example, in the following graphic, right-clicking the reference block shows that the
reference block has locally created requirements links and requirements links on the
library block:

• Locally created requirements links — Can be modified or deleted without changing
the library block:

• Manifold absolute pressure sensor
• Mass airflow estimation

• Requirements links on the library block — Cannot be modified or deleted from the
context of the reference block:

• Speed sensor
• Throttle sensor
• Oxygen sensor
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Manage Requirements Inside Reference Blocks

If your library block is a subsystem or a Stateflow atomic subchart, you can create
requirements links on objects inside the subsystem or subchart. If you disable the link
from the reference block to the library, you can add, modify, or delete requirements links
on objects inside a reference block. Once you have disabled the link, the RMI treats those
links as locally created links.

After you make changes to requirements links on objects inside a reference block, you
can resolve the link so that those changes are pushed to the library block. The next time
you create an instance of that library block, the changes you made are copied to the new
instance of the library block.

The workflow for creating a requirement link on an object inside a reference block is:

1 Within a library you have a subsystem S1. Drag S1 to a model, creating a new
subsystem. This subsystem is the reference block.
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2 Disable the library link between the reference block and the library block. Keep the
library loaded while you disable the link to maintain RMI data. To disable the link,
select the reference block and select Diagram > Library Link > Disable Link.

3 Create a link from the object inside the reference block to the requirements
document.

S1

Disabled
library link

Library

S1

Requirements
   document

RequirementLink to
requirement

Library
block

Reference
block

Model 1

Note When linking to a requirement from inside a reference block, you can create
links only in one direction: from the model to the requirements document. The RMI
does not support inserting navigation objects into requirements documents for
objects inside reference blocks.

4 Resolve the library link between the reference block and the library block:

a Select the reference block.
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b Select Diagram > Library Link > Resolve Link.
c In the Action column, click Push.
d Click OK to resolve the link to the library block and push the newly added

requirement to the object inside the library block.

When you resolve the library link between the library block and the subsystem,
Simulink pushes the new requirement link to the library block S1. The following
graphic shows the new link from inside the library block S1 to the requirement.
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Library
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requirement

Reference
block

Library
block
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Note If you see a message that the library is locked, you must unlock the library
before you can push the changes to the library block.

5 If you reuse library block S1, which now has an object with a requirement link, in
another model, the new subsystem contains an object that links to that requirement.
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Links from Requirements to Library Blocks

If you have a requirement that links to a library block and you drag that library block to
a model, the requirement does not link to the reference block; the requirement links only
to the library block.

For example, consider the situation where you have established linking between a library
block (B1 in the following graphic) and a requirement in both directions.
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When you use library block B1 in a model, you can navigate from the reference block to
the requirement. However, the link from the requirement still points only to library block
B1, not to the reference block.
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   document

Library

Requirement

B1

B1

Library
link

Link to
requirement

Links to and from
a requirement

Library
block

Reference
block

Model

As discussed in the previous section, you can create requirements links on objects inside
instances of library block after disabling library links. However, the RMI prohibits you
from creating a link from the requirements document to such an object because that link
would become invalid when you restored the library link.
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Synchronization with DOORS Surrogate Modules
Synchronization is a user-initiated process that creates or updates a DOORS surrogate
module. A surrogate module is a DOORS formal module that is a representation of a
Simulink model hierarchy.

When you synchronize a model for the first time, the DOORS software creates a
surrogate module. The surrogate module contains a representation of the model,
depending on your synchronization settings. (To learn how to customize the links and
level of detail in the synchronization, see “Customize DOORS Synchronization” on page
5-130.)

If you create or remove model objects or links, keep your surrogate module up to date by
resynchronizing. The updated surrogate module reflects any changes in the requirements
links since the previous synchronization.

Note The RMI and DOORS software both use the term object. In the RMI, and in this
document, the term object refers to a Simulink model or block, or to a Stateflow chart or
its contents.

In the DOORS software, object refers to numbered elements in modules. The DOORS
software assigns each of these objects a unique object ID. In this document, these objects
are referred to as DOORS objects.

You use standard DOORS capabilities to navigate between the Simulink objects in the
surrogate module and requirements in other formal modules. The surrogate module
facilitates navigation between the Simulink model object and the requirements, as the
following diagram illustrates.
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Advantages of Synchronizing Your Model with a Surrogate
Module

Synchronizing your Simulink model with a surrogate module offers the following
advantages:

• You can navigate from a requirement to a Simulink object without modifying the
requirements modules.

• You avoid cluttering your requirements modules with inserted navigation objects.
• The DOORS database contains complete information about requirements links. You

can review requirements links and verify traceability, even if the Simulink software is
not running.

• You can use DOORS reporting features to analyze requirements coverage.
• You can separate the requirements tracking work from the Simulink model

developers' work, as follows:

• Systems engineers can establish requirements links to models without using the
Simulink software.

• Model developers can capture the requirements information using synchronization
and store it with the model.

• You can resynchronize a model with a new surrogate module, updating any model
changes or specifying different synchronization options.
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Synchronize a Simulink Model to Create a Surrogate Module
The first time that you synchronize your model with the DOORS software, the DOORS
software creates a surrogate module.

In this tutorial, you synchronize the sf_car model with the DOORS software.

Note Before you begin, make sure you know how to create links from a Simulink model
object to a requirement in a DOORS database. For a tutorial on creating links to DOORS
requirements, see “Link to Requirements in IBM Rational DOORS Databases” on page 5-
39.

1 To create a surrogate module, start the DOORS software and open a project. If the
DOORS software is not already running, start the DOORS software and open a
project.

2 Open the sf_car model.
3 Rename the model to sf_car_doors, and save the model in a writable folder.
4 Create links to a DOORS formal module from two objects in sf_car_doors:

• The transmission subsystem
• The engine torque block inside the Engine subsystem

5 Save the changes to the model.
6 In the Simulink Editor, select Analysis > Requirements Traceability >

Synchronize with DOORS.

The DOORS synchronization settings dialog box opens.
7 For this tutorial, accept the default synchronization options.

The default option under Extra mapping additionally to objects with links,
None, creates objects in the surrogate module only for the model and any model
objects with links to DOORS requirements.

Note For more information about the synchronization options, see “Customize
DOORS Synchronization” on page 5-130.

8 Click Synchronize to create and open a surrogate module for all DOORS
requirements that have links to objects in the sf_car_doors model.
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After synchronization with the None option, the surrogate module, a formal module
named sf_car_doors, contains:

• A top-level object for the model (sf_car_doors)
• Objects that represent model objects with links to DOORS requirements

(transmission, engine torque), and their parent objects (Engine).

9 Save the surrogate module and the model.
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Create Links Between Surrogate Module and Formal Module in a
DOORS Database

The surrogate module is the interface between the DOORS formal module that contains
your requirements and the Simulink model. To establish links between the surrogate
module and the requirements module, copy the link information from the model to the
surrogate module:

1 Open the sf_car_doors model.
2 In the Simulink Editor, select Analysis > Requirements Traceability >

Synchronize with DOORS.
3 In the DOORS synchronization settings dialog box, select two options:

• Update links during synchronization
• from Simulink to DOORS.

4 Click Synchronize.

The RMI creates links from the DOORS surrogate module to the formal module.
These links correspond to links from the Simulink model to the formal module. In
this example, the DOORS software copies the links from the engine torque block and
transmission subsystems to the formal module, as indicated by the red triangles.
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Customize DOORS Synchronization
In this section...
“DOORS Synchronization Settings” on page 5-130
“Resynchronize a Model with a Different Surrogate Module” on page 5-132
“Customize the Level of Detail in Synchronization” on page 5-133
“Resynchronize to Include All Simulink Objects” on page 5-134

DOORS Synchronization Settings

When you synchronize your Simulink model with a DOORS database, you can:

• Customize the level of detail for your surrogate module.
• Update links in the surrogate module or in the model to verify the consistency of

requirements links among the model, and the surrogate and formal modules.

The DOORS synchronization settings dialog box provides the following options during
synchronization.

DOORS Settings Option Description
DOORS surrogate module path and name Specifies a unique DOORS path to a new or an

existing surrogate module.

For information about how the RMI resolves the
path to the requirements document, see
“Document Path Storage” on page 5-113.

Extra mapping additionally to objects with
links

Determines the completeness of the Simulink
model representation in the DOORS surrogate
module. None specifies synchronizing only those
Simulink objects that have linked requirements,
and their parent objects. For more information
about these synchronization options, see
“Customize the Level of Detail in
Synchronization” on page 5-133.
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DOORS Settings Option Description
Update links during synchronization Specifies updating any unmatched links the

RMI encounters during synchronization, as
designated in the Copy unmatched links and
Delete unmatched links options.

Copy unmatched links During synchronization, selecting the following
options has the following results:

• from Simulink to DOORS: For links
between the model and the formal module,
the RMI creates matching links between the
DOORS surrogate and formal modules.

• from DOORS to Simulink: For links
between the DOORS surrogate and formal
modules, the RMI creates matching links
between the model and the DOORS modules.

Delete unmatched links During synchronization, selecting the following
options has the following results:

• Remove unmatched in DOORS: For links
between the formal and surrogate modules,
when there is not a corresponding link
between the model and the DOORS modules,
the RMI deletes the link in DOORS.

This option is available only if you select the
from Simulink to DOORS option.

• Remove unmatched in Simulink: For
links between the model and the DOORS
modules, when there is not a corresponding
link between the formal and surrogate
modules, the RMI deletes the link from the
model.

This option is available only if you select the
from DOORS to Simulink option.
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DOORS Settings Option Description
Save DOORS surrogate module After the synchronization, saves changes to the

surrogate module and updates the version of the
surrogate module in the DOORS database.

Save Simulink model (recommended) After the synchronization, saves changes to the
model. If you use a version control system,
selecting this option changes the version of the
model.

Resynchronize a Model with a Different Surrogate Module

You can synchronize the same Simulink model with a new DOORS surrogate module.
For example, you might want the surrogate module to contain only objects that have
requirements to DOORS, rather than all objects in the model. In this case, you can
change the synchronization options to reduce the level of detail in the surrogate module:

1 In the DOORS synchronization settings dialog box, change the DOORS surrogate
module path and name to the path and name of the new surrogate module in the
DOORS database.

2 Specify a module with either a relative path (starting with ./) or a full path
(starting with /).

The software appends relative paths to the current DOORS project. Absolute paths
must specify a project and a module name.

When you synchronize a model, the RMI automatically updates the DOORS
surrogate module path and name with the actual full path. The RMI saves the
unique module ID with the module.

3 If you select a new module path or if you have renamed the surrogate module, and
you click Synchronize, the Requirements: Surrogate Module Mismatch dialog box
opens.
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4 Click Continue to create a new surrogate module with the new path or name.

Customize the Level of Detail in Synchronization

You can customize the level of detail in a surrogate module so that the module reflects
the full or partial Simulink model hierarchy.

In “Synchronize a Simulink Model to Create a Surrogate Module” on page 5-127, you
synchronized the model with the Extra mapping additionally to objects with links
option set to None. As a result, the surrogate module contains only Simulink objects that
have requirement links, and their parent objects. Additional synchronization options,
described in this section, can increase the level of surrogate detail. Increasing the level of
surrogate detail can slow down synchronization.

The Extra mapping additionally to objects with links option can have one of the
following values. Each subsequent option adds additional Simulink objects to the
surrogate module. You choose None to minimize the surrogate size or Complete to create
a full representation of your model. The Complete option adds all Simulink objects to
the surrogate module, creating a one-to-one mapping of the Simulink model in the
surrogate module. The intermediate options provide more levels of detail.

Drop-Down List Option Description
None (Recommended for better
performance)

Maps only Simulink objects that have requirements links
and their parent objects to the surrogate module.

Minimal - Non-empty unmasked
subsystems and Stateflow
charts

Adds all nonempty Stateflow charts and unmasked
Simulink subsystems to the surrogate module.
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Drop-Down List Option Description
Moderate - Unmasked
subsystems, Stateflow charts,
and superstates

Adds Stateflow superstates to the surrogate module.

Average - Nontrivial Simulink
blocks, Stateflow charts and
states

Adds all Stateflow charts and states and Simulink blocks,
except for trivial blocks such as ports, bus objects, and
data-type converters, to the surrogate module.

Extensive - All unmasked
blocks, subsystems, states and
transitions

Adds all unmasked blocks, subsystems, states, and
transitions to the surrogate module.

Complete - All blocks,
subsystems, states and
transitions

Copies all blocks, subsystems, states, and transitions to
the surrogate module.

Resynchronize to Include All Simulink Objects

This tutorial shows how you can include all Simulink objects in the DOORS surrogate
module. Before you start these steps, make sure you have completed the tutorials
“Synchronize a Simulink Model to Create a Surrogate Module” on page 5-127 and
“Create Links Between Surrogate Module and Formal Module in a DOORS Database” on
page 5-129.

1 Open the sf_car_doors model that you synchronized in “Synchronize a Simulink
Model to Create a Surrogate Module” on page 5-127 and again in “Create Links
Between Surrogate Module and Formal Module in a DOORS Database” on page 5-
129.

2 In the Simulink Editor, select Analysis > Requirements Traceability >
Synchronize with DOORS.

The DOORS synchronization settings dialog box opens.
3 Resynchronize with the same surrogate module, making sure that the DOORS

surrogate module path and name specifies the surrogate module path and name
that you used in “Synchronize a Simulink Model to Create a Surrogate Module” on
page 5-127.

For information about how the RMI resolves the path to the requirements document,
see “Document Path Storage” on page 5-113.
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4 Update the surrogate module to include all objects in your model. To do this, under
Extra mapping additionally to objects with links, from the drop-down list,
select Complete - All blocks, subsystems, states and transitions.

5 Click Synchronize.

After synchronization, the DOORS surrogate module for the sf_car_doors model
opens with the updates. All Simulink objects and all Stateflow objects in the
sf_car_doors model are now mapped in the surrogate module.

 Customize DOORS Synchronization

5-135



6 Scroll through the surrogate module. Notice that the objects with requirements (the
engine torque block and transmission subsystem) retain their links to the DOORS
formal module, as indicated by the red triangles.

7 Save the surrogate module.

Detailed Information About The Surrogate Module You Created

Notice the following information about the surrogate module that you created in
“Resynchronize to Include All Simulink Objects” on page 5-134:

• The name of the surrogate module is sf_car_doors, as you specified in the DOORS
synchronization settings dialog box.

• DOORS object headers are the names of the corresponding Simulink objects.
• The Block Type column identifies each object as a particular block type or a

subsystem.
• If you delete a previously synchronized object from your Simulink model and then

resynchronize, the Block Deleted column reads true. Otherwise, it reads false.

These objects are not deleted from the surrogate module. The DOORS software
retains these surrogate module objects so that the RMI can recover these links if you
later restore the model object.

• Each Simulink object has a unique ID in the surrogate module. For example, the ID
for the surrogate module object associated with the Mux block in the preceding figure
is 11.

• Before the complete synchronization, the surrogate module contained the
transmission subsystem, with an ID of 3. After the complete synchronization, the
transmission object retains its ID (3), but is listed farther down in the surrogate
module. This order reflects the model hierarchy. The transmission object in the
surrogate module retains the red arrow that indicates that it links to a DOORS
formal module object.
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Resynchronize DOORS Surrogate Module to Reflect Model
Changes

If you change your model after synchronization, the RMI does not display a warning
message. If you want the surrogate module to reflect changes to the Simulink model,
resynchronize your model.

In this tutorial, you add a new block to the sf_car_doors model, and later delete it,
resynchronizing after each step:

1 In the sf_car_doors model, make a copy of the vehicle mph (yellow) & throttle %
Scope block and paste it into the model. The name of the new Scope block is vehicle
mph (yellow) & throttle %1.

2 Select Analysis > Requirements Traceability > Synchronize with DOORS.
3 In the DOORS synchronization settings dialog box, leave the Extra mapping

additionally to objects with links option set to Complete - All blocks,
subsystems, states, and transitions. Click Synchronize.

After the synchronization, the surrogate module includes the new block.

4 In the sf_car_doors model, delete the newly added Scope block and resynchronize.

The block that you delete appears at the bottom of the list of objects in the surrogate
module. Its entry in the Block Deleted column reads True.
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5 Delete the copied object (vehicle mph (yellow) & throttle %1 and resynchronize the
model.

6 Save the surrogate module.
7 Save the sf_car_doors model.
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Navigate with the Surrogate Module

In this section...
“Navigate Between Requirements and the Surrogate Module in the DOORS Database”
on page 5-139
“Navigate Between DOORS Requirements and the Simulink Module via the Surrogate
Module” on page 5-140

Navigate Between Requirements and the Surrogate Module in the
DOORS Database

The surrogate module and the requirements in the formal module are both in the
DOORS database. When you synchronize your model, the DOORS software creates links
between the surrogate module objects and the requirements in the DOORS database.

Navigating between the requirements and the surrogate module allows you to review the
requirements that have links to the model without starting the Simulink software.

To navigate from the surrogate module transmission object to the requirement in the
formal module:

1 In the surrogate module object for the transmission subsystem, right-click the right-
facing red arrow.

2 Select the requirement name.

The formal module opens, at the Transmission Requirements object.

To navigate from the requirement in the formal module to the surrogate module:

1 In the Transmission Requirements object in the formal module, right-click the left-
facing orange arrow.
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2 Select the object name.

The surrogate module for sf_car_doors opens, at the object associated with the
transmission subsystem.

Navigate Between DOORS Requirements and the Simulink Module via
the Surrogate Module

You can create links that allow you to navigate from Simulink objects to DOORS
requirements and from DOORS requirements to the model. If you synchronize your
model, the surrogate module serves as an intermediary for the navigation in both
directions. The surrogate module allows you to navigate in both directions even if you
remove the direct link from the model object to the DOORS formal module.

Navigate from a Simulink Object to a Requirement via the Surrogate Module

To navigate from the transmission subsystem in the sf_car_doors model to a
requirement in the DOORS formal module:

1 In the sf_car_doors model, right-click the transmission subsystem and select
Requirements Traceability > 1. “DOORS Surrogate Item”. (The direct link to
the DOORS formal module is also available.)

The surrogate module opens, at the object associated with the transmission
subsystem.

2 To display the individual requirement, in the surrogate module, right-click the right-
facing red arrow and select the requirement.

The formal module opens, at Transmission Requirements.
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Navigate from a Requirement to the Model via the Surrogate Module

To navigate from the Transmission Requirements requirement in the formal module
to the transmission subsystem in the sf_car_doors model:

1 In the formal module, in the Transmission Requirements object, right-click the
left-facing orange arrow.

2 Select the path to the linked surrogate object: /sf_car Project/sf_car_doors > 4.
transmission.

The surrogate module opens, at the transmission object.
3 In the surrogate module, select MATLAB > Select item.

The linked object is highlighted in sf_car_doors.
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Why Add Navigation Objects to DOORS Requirements?
IBM Rational DOORS software is a requirements management application that you use
to capture, track, and manage requirements. The Requirements Management Interface
(RMI) allows you to link Simulink objects to requirements managed by external
applications, including the DOORS software.

When you create a link from a Simulink object to a DOORS requirement, the RMI stores
the link data in Simulink. Using this link, you can navigate from the Simulink object to
its associated requirement.

You can also configure the RMI to insert a navigation object in the DOORS database.
This navigation object serves as a link from the DOORS requirement to its associated
Simulink object.

To insert navigation objects into a DOORS database, you must have write access to the
DOORS database.
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Configure Requirements Management Interface for DOORS
Software

In this section...
“Before You Begin” on page 5-143
“Manually Install Additional Files for DOORS Software” on page 5-143

Before You Begin

If you plan to use DOORS software with the RMI, make sure to install additional files to
establish communication between the DOORS application and the Simulink software.
Follow the instructions in “Configure RMI for Interaction with Microsoft Office
Applications and IBM Rational DOORS Software” on page 5-17.

Manually Install Additional Files for DOORS Software

The setup script automatically copies the required DOORS files to the installation
folders. However, the script might fail because of file permissions in your DOORS
installation. If the script fails, change the file permissions on the DOORS installation
folders and rerun the script.

You can also manually install the required files into the specified folders, as described in
the following steps:

1 If the DOORS software is running, close the application.
2 Copy the following files from matlabroot\toolbox\shared\reqmgt\dxl to the

<doors_install_dir>\lib\dxl\addins folder.

addins.idx
addins.hlp

If you have not modified the files, replace any existing versions of the files;
otherwise, merge the contents of both files into a single file.

3 Copy the following files from matlabroot\toolbox\shared\reqmgt\dxl to the
<doors_install_dir>\lib\dxl\addins\dmi folder.

dmi.hlp
dmi.idx
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dmi.inc
runsim.dxl
selblk.dxl

Replace any existing versions of these files.
4 Open the <doors_install_dir>\lib\dxl\startup.dxl file. In the user-defined

files section, add the following include statement:

#include <addins/dmi/dmi.inc>

If you upgrade from Version 7.1 to a later version of the DOORS software, perform
these additional steps:

a In your DOORS installation folder, navigate to the ...\lib\dxl
\startupFiles subfolder.

b In a text editor, open the copiedFromDoors7.dxl file.
c Add // before this line to comment it out:

#include <addins/dmi/dmi.inc>
d Save and close the file.

5 Start the DOORS and MATLAB software.
6 Run the setup script using the following MATLAB command.

rmi setup
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Enable Linking from DOORS Databases to Simulink Objects
By default, the RMI does not insert navigation objects into requirements documents. If
you want to insert a navigation object into the requirements document when you create a
link from a Simulink object to a requirement, you must change the RMI’s settings. The
following tutorial uses the sldemo_fuelsys example model to illustrate how to do this.

To enable linking from the DOORS database to the example model:

1 Open the model:

sldemo_fuelsys

Note You can modify requirements settings in the Requirements Settings dialog box.
These settings are global and not specific to open models. Changes you make apply
not only to open models, but also persist for models you subsequently open. For more
information about these settings, see “Requirements Settings” on page 5-23.

2 Select Analysis > Requirements Traceability > Settings.

The Requirements Settings dialog box opens.
3 Click the Selection Linking tab.
4 Select Modify destination for bidirectional linking.

When you enable this option, every time you create a selection-based link from a
Simulink object to a requirement, the RMI inserts navigation objects at the
designated location. Using this option requires write access to the requirements
document.

5 Select Store absolute path to model file.

For this exercise, you save a copy of the example model on the MATLAB path.

If you add requirements to a model that is not on the MATLAB path, you must select
this option to enable linking from your requirements document to your model.

6 In the Apply this user tag to new links field, enter one or more user tags to apply
to the links that you create.

For more information about user tags, see “User Tags and Requirements Filtering”
on page 5-90.
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7 Click Close to close the Requirements Settings dialog box. Keep the
sldemo_fuelsys model open.
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Insert Navigation Objects into DOORS Requirements
When you enable Modify destination for bidirectional linking as described in
“Enable Linking from DOORS Databases to Simulink Objects” on page 5-145, the RMI
can insert a navigation object into both the Simulink object and its associated DOORS
requirement. This tutorial uses the sldemo_fuelsys example model to illustrate how to
do this. For this tutorial, you also need a DOORS formal module that contains
requirements.

1 Rename the sldemo_fuelsys model and save it in a writable folder on the
MATLAB path.

2 Start the DOORS software and open a formal module that contains requirements.
3 Select the requirement that you want to link to by left-clicking that requirement in

the DOORS database.
4 In the sldemo_fuelsys model, select an object in the model.

This example creates a requirement from the fuel_rate_control subsystem.
5 Right-click the Simulink object (in this case, the fuel_rate_control subsystem)

and select Requirements Traceability > Link to Selection in DOORS.

The RMI creates the link for the fuel_rate_control subsystem. It also inserts a
navigation object into the DOORS formal module—a Simulink reference object ( )
that enables you to navigate from the requirement to the model.

6 Close the model.

Note When you navigate to a DOORS requirement from outside the software, the
DOORS module opens in read-only mode. If you want to modify the DOORS module,
open the module using DOORS software.
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Insert Navigation Objects to Multiple Simulink Objects

If you have several Simulink objects that correspond to one requirement, you can link
them all to that requirement with a single navigation object. This eliminates the need to
insert multiple navigation objects for a single requirement. The Simulink objects must be
available in the same model diagram or Stateflow chart.

The workflow for linking multiple Simulink objects to one DOORS requirement is as
follows:

1 Make sure that you have enabled Modify destination for bidirectional linking.
2 Select the DOORS requirement to link to.
3 Select the Simulink objects that need to link to that requirement.
4 Right-click one of the objects and select Requirements Traceability > Link to

Selection in DOORS.

A single navigation object is inserted at the selected requirement.
5 Double-click the navigation object in DOORS to highlight the Simulink objects that

are linked to that requirement.
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Customize DOORS Navigation Objects
If the RMI is configured to modify the destination for bidirectional linking as described in
“Enable Linking from DOORS Databases to Simulink Objects” on page 5-145, the RMI
can insert a navigation object into your requirements document. This object looks like the
icon for the Simulink software: 

Note In IBM Rational DOORS requirements documents, clicking a navigation object does
not navigate back to your Simulink object. Select MATLAB > Select object to find the
Simulink object that contains the requirements link.

To use an icon of your choosing for the navigation object:

1 Select Analysis > Requirements Traceability > Settings.
2 Select the Selection Linking tab.
3 Select Modify destination for bidirectional linking.

Selecting this option enables the Use custom bitmap for navigation controls in
documents option.

4 Select Use custom bitmap for navigation controls in documents.
5 Click Browse to locate the file you want to use for the navigation objects.

For best results, use an icon file (.ico) or a small (16×16 or 32×32) bitmap image
(.bmp) file for the navigation object. Other types of image files might give
unpredictable results.

6 Select the desired file to use for navigation objects and click Open.
7 Close the Requirements Settings dialog box.

The next time you insert a navigation object into a requirements document, the RMI uses
the file you selected.

Tip You can specify a custom template for labels of requirements links to DOORS objects.
For more information, see the rmi command.
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Navigate Between DOORS Requirement and Model Object
In “Insert Navigation Objects into DOORS Requirements” on page 5-147, you created a
link between a DOORS requirement and the fuel_rate_control subsystem in the
sldemo_fuelsys model. Navigate the links in both directions:

1 With the sldemo_fuelsys model closed, go to the DOORS requirement in the
formal module.

2 Left-click the Simulink reference object that you inserted to select it.
3 Select MATLAB > Select item.

Your version of the sldemo_fuelsys model opens, with the fuel_rate_control
subsystem highlighted.

4 Log in to the DOORS software.
5 Navigate from the model to the DOORS requirement. In the Model Editor, right-

click the fuel_rate_control subsystem and select Requirements Traceability > 1.
“<requirement name>” where <requirement name> is the name of the DOORS
requirement that you created.

The DOORS formal module opens with the requirement object and its child objects
highlighted in red.
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Diagnose and Fix DXL Errors
If you try to synchronize your Simulink model to a DOORS project, you might see the
following errors:

-E- DXL: <Line:2> incorrectly concatenated tokens
-E- DXL: <Line:2> undeclared variable (dmiRefreshModule)
-I- DXL: all done with 2 errors and 0 warnings

If you see these errors, exit the DOORS software, rerun the steps in “Configure RMI for
Interaction with Microsoft Office Applications and IBM Rational DOORS Software” on
page 5-17, and restart the DOORS software.
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Why Add Navigation Objects to Microsoft Office Requirements?
You can use the Microsoft Word and Microsoft Excel applications to capture, track, and
manage requirements. The Requirements Management Interface (RMI) allows you to
link Simulink objects to requirements managed by external applications.

When you create a link from a Simulink object to a requirement in a Microsoft Office
document, the RMI stores the link data in Simulink. Using this link, you can navigate
from the Simulink object to its associated requirement.

You can also configure the RMI to insert a navigation object in a Microsoft Office
requirements document. This navigation object serves as a link from the requirement to
its associated Simulink object.

 Why Add Navigation Objects to Microsoft Office Requirements?

5-153



Enable Linking from Microsoft Office Documents to Simulink
Objects

By default, the RMI does not insert navigation objects into requirements documents. If
you want to insert a navigation object into the requirements document when you create a
link from a Simulink object to a requirement, you must change the RMI’s settings. The
following tutorial uses the slvnvdemo_fuelsys_officereq example model to
illustrate how to do this.

The RMI can insert navigation objects into the following Microsoft Office applications:

• Microsoft Excel
• Microsoft Word

To enable linking from a Microsoft Office document to the example model:

1 Open the model:

slvnvdemo_fuelsys_officereq

Note You can modify requirements settings in the Requirements Settings dialog box.
These settings are global and not specific to open models. Changes you make apply
not only to open models, but also persist for models you subsequently open. For more
information about these settings, see “Requirements Settings” on page 5-23.

2 Select Analysis > Requirements Traceability > Settings.

The Requirements Settings dialog box opens.
3 On the Selection Linking tab of the Requirements Settings dialog box:

• Enable Modify destination for bidirectional linking.

When you select this option, every time you create a selection-based link from a
Simulink object to a requirement, the RMI inserts a navigation object at the
designated location in the requirements document.

• To specify one or more user tags to apply to the links that you create, in the
Apply this user tag to new links field, enter the tag names.

For more information about user tags, see “User Tags and Requirements
Filtering” on page 5-90.
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4 Click Close to close the Requirements Settings dialog box. Keep the
slvnvdemo_fuelsys_officereq model open.
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Insert Navigation Objects in Microsoft Office Requirements
Documents

Use selection-based linking to create a link from the slvnvdemo_fuelsys_officereq
model to a requirements document. If you have configured the RMI as described in
“Enable Linking from Microsoft Office Documents to Simulink Objects” on page 5-154,
the RMI can insert a navigation object into the requirements document.

1 Open the Microsoft Word requirements document:
matlabroot/toolbox/slvnv/rmidemos/fuelsys_req_docs/
slvnvdemo_FuelSys_RequirementsSpecification.docx

2 Select the Throttle Sensor header.
3 In the slvnvdemo_fuelsys_officereq model, open the engine gas dynamics

subsystem.
4 Right-click the Throttle & Manifold subsystem and select Requirements

Traceability > Link to Selection in Word.
5 The RMI inserts an URL-based link into the requirements document.

Insert Navigation Object That Links to Multiple Simulink Objects

If you have several Simulink objects that correspond to one requirement, you can link
them all to that requirement with a single navigation object. This eliminates the need to
insert multiple navigation objects for a single requirement. The Simulink objects must be
available in the same model diagram or Stateflow chart.

The workflow for linking multiple Simulink objects to one Microsoft Word requirement is
as follows:

1 Make sure that the RMI is configured to insert navigation objects into requirements
documents, as described in “Enable Linking from Microsoft Office Documents to
Simulink Objects” on page 5-154.

2 Select the Microsoft Word requirement to link to.
3 Select the Simulink objects that need to link to that requirement.
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4 Right-click one of the Simulink objects and select Requirements Traceability >
Link to Selection in Word.

A single navigation object is inserted at the selected requirement.
5 Follow the navigation object link in Microsoft Word to highlight the Simulink objects

that are linked to that requirement.
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Customize Microsoft Office Navigation Objects
If the RMI is configured to modify destination for bidirectional linking, the RMI inserts a
navigation object into your requirements document. This object looks like the icon for the
Simulink software: 

Note In Microsoft Office requirements documents, following a navigation object link
highlights the Simulink object that contains a bidirectional link to the associated
requirement.

To use an icon of your own choosing for the navigation object:

1 Select Analysis > Requirements Traceability > Settings.
2 Select the Selection Linking tab.
3 Select Modify destination for bidirectional linking.

Selecting this option enables the Use custom bitmap for navigation controls in
documents option.

4 Select Use custom bitmap for navigation controls in documents.
5 Click Browse to locate the file you want to use for the navigation objects.

For best results, use an icon file (.ico) or a small (16×16 or 32×32) bitmap image
(.bmp) file for the navigation object. Other types of image files might give
unpredictable results.

6 Select the desired file to use for navigation objects and click Open.
7 Close the Requirements Settings dialog box.

The next time you insert a navigation object into a requirements document, the RMI uses
the file you selected.
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Navigate Between Microsoft Word Requirement and Model
In “Insert Navigation Objects in Microsoft Office Requirements Documents” on page 5-
156, you created a link between a Microsoft Word requirement and the Throttle &
Manifold subsystem in the slvnvdemo_fuelsys_officereq example model. Navigate
these links in both directions:

1 In the slvnvdemo_fuelsys_officereq model, right-click the Throttle & Manifold
subsystem and select Requirements Traceability > 1. “Throttle Sensor”.

The requirements document opens, and the header in the requirements document is
highlighted.

2 In the requirements document, next to Throttle Sensor, follow the navigation
object link.

The engine gas dynamics subsystem opens, with the Throttle & Manifold subsystem
highlighted.

Navigation from Microsoft Office requirements documents is not automatically enabled
upon MATLAB startup. Navigation is enabled when you create a new requirements link
or when you have enabled bidirectional linking as described in “Insert Navigation
Objects in Microsoft Office Requirements Documents” on page 5-156.

Note You cannot navigate to requirements from Microsoft Word 2013 onwards when the
document is open in read-only mode. Alternately, consider disabling the “Open e-mail
attachments and other uneditable files in reading view” option in the Microsoft Word
options or using editable documents.
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When attempting navigation from requirements links with the  icon, if you get a
“Server Not Found” or similar message, enter the command rmi('httpLink') to
activate the internal MATLAB HTTP server.
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Navigate with Objects Created Using ActiveX in Microsoft Office
2007 and 2010

In this section...
“Save Requirements Documents to Microsoft Word 2007 or 2010 Format” on page 5-161
“Field Codes in Requirements Documents” on page 5-162
“ActiveX Control Does Not Link to Model Object” on page 5-164
“Delete an ActiveX Control from Microsoft Excel 2007” on page 5-166
“Delete an ActiveX Control from Microsoft Excel 2010” on page 5-166

Save Requirements Documents to Microsoft Word 2007 or 2010
Format

If you create a requirements document with an earlier version of Microsoft Word than
Word 2007, links to the corresponding Simulink objects automatically work. If you open a
document created in an earlier version and then save it in Microsoft Word 2007 format,
make sure that the links to the models continue to work:

1 Open a requirements document saved in a release of Microsoft Word earlier than
Microsoft Word 2007.

2 Depending on which version of Microsoft Word you are running, do one of the
following:

• In Microsoft Word 2007, in the upper-left corner, click the Microsoft Office
Button.

• In Microsoft Word 2010, select the File tab.
3 Select Save As > Word Document.

You see the following dialog box.
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4 Click OK.

If you are running Microsoft Word 2007, you see the following dialog box.

5 Click Yes to save the current document in the current Microsoft Word format, with
a .docx extension.

Note You might need to enable ActiveX controls in the Microsoft Office Trust Center.

Field Codes in Requirements Documents

If your Microsoft Word requirements document displays the field codes in addition to, or
instead of, the ActiveX icon, clear the Show field codes instead of their values
option.

The following graphic shows a requirements document created in Microsoft Word 2003,
with the field codes (CONTROL mwSimulink1.SLRefButton \s) displayed.
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The following graphic shows a requirements document created in Microsoft Word 2007,
with the field codes (CONTROL mwSimulink1.SLRefButton) displayed.

To hide the field codes and display the ActiveX icon:

1 Depending on which version of Microsoft Word you are running, do one of the
following:

• In Microsoft Word 2007, in the upper-left corner, click the Microsoft Office
Button and at the bottom of the window, click Word Options.

• In Microsoft Word 2010, select File > Options.
2 In the left-hand portion of the pane, click Advanced.
3 In the Advanced pane, scroll to the Show document content section and clear the

Show field codes instead of their values option.
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ActiveX Control Does Not Link to Model Object
If you click an ActiveX control that links to a Simulink or Stateflow object, and the object
does not open, do one of the following:

• Store your requirements documents in trusted locations, as described in the Microsoft
Office 2007 documentation. The Trust Center does not check files for ActiveX controls
stored in trusted locations, so you can maintain your Trust Center restrictions.

• Enable ActiveX controls:

1 Depending on which version of Microsoft Office you are using, do one of the
following:
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• In Microsoft Word 2007 or Microsoft Excel 2007, in the upper-left corner, click
the Microsoft Office Button.

In the pane that opens, at the bottom, click Word Options or Excel Options,
depending on which program you are running.

• In Microsoft Word 2010 or Microsoft Excel 2010, select File > Options.
2 In the left-hand portion of the pane, click Trust Center.
3 In the Trust Center pane, click Trust Center Settings.
4 In the Trust Center pane, on the right, select ActiveX Settings.

5 Select the setting that you want for ActiveX controls:

• Prompt me for enabling all controls with minimal restrictions to
decide each time you click an ActiveX control if you want to enable all
controls.

• Enable all controls without restrictions and without prompting to
enable all ActiveX controls whenever you open the document.

6 Close the open dialog boxes.
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7 Restart the application for the settings to take effect.

Delete an ActiveX Control from Microsoft Excel 2007
Your document may have an ActiveX control in a worksheet cell:

To remove an ActiveX control from your Microsoft Excel 2007 spreadsheet:

1 In Microsoft Excel 2007, in the upper-left corner, click the Microsoft Office
Button.

2 In the pane that opens, at the bottom, click Excel Options.
3 In the Microsoft Excel Options dialog box, in the left-hand pane, click Popular.
4 On the Popular pane, in the Top options for working with Excel section, select

Show Developer tab in the Ribbon.
5 Click OK.
6 In the Ribbon, on the Developer tab, select Design Mode.

When you select Design Mode, the ActiveX control is no longer visible in the cell.
7 Click where the ActiveX control was, and you see four handles showing the location

of the control.

8 Select Home > Cut to delete the control.

Delete an ActiveX Control from Microsoft Excel 2010
Your document may have an ActiveX control in a worksheet cell:
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To remove an ActiveX control from your Microsoft Excel 2010 spreadsheet:

1 Select the control by clicking it.
2 Select Home > Cut to delete the control.
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Link Between MATLAB Code Lines and Requirements
Information in External Documents

In this section...
“Create Link Using Context Menu Shortcuts” on page 5-168
“Create Link Using Link Editor” on page 5-168

Create Link Using Context Menu Shortcuts

To create requirements traceability links from MATLAB code lines to selections in
Microsoft Word, Microsoft Excel, or IBM Rational DOORS documents, you can use
shortcuts in the Requirements Traceability context menu.

1 In your requirements document, select the target for the traceability link that you
want to create.

2 In the MATLAB Editor, select the line or lines of code that you want to link.
3 In the MATLAB Editor, right-click your selection.
4 From the context menu, select Requirements Traceability. Depending on the type

of your requirements document, select one of the following options:

• Link to Selection in Word
• Link to Selection in Excel
• Link to Selection in DOORS

The software creates a traceability link from the selected MATLAB code range to the
selection in the requirements document. It also inserts a navigation object for the
selection in the requirements document. The navigation object links to the selected
MATLAB code range.

Create Link Using Link Editor

You can create, edit, and delete traceability links with the Link Editor. To open the Link
Editor:

• In the MATLAB Editor, select the line or lines of code that you want to link.
• Right-click your selection.
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• From the context menu, select Requirements Traceability > Open Link Editor.

For detailed information on the Link Editor, see “Requirements Traceability Link Editor”
on page 5-20.
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Enable or Disable Highlighting of Traceability Links for MATLAB
Code

In this section...
“Enable Traceability Highlighting of MATLAB Code” on page 5-170
“Disable Traceability Highlighting of MATLAB Code” on page 5-170

Enable Traceability Highlighting of MATLAB Code

To highlight traceability links in your MATLAB code, do one of the following:

• In the View tab, in the Display section, select Highlight Traceability.
• In the MATLAB Editor, right-click in a line of code with a traceability link. From the

context menu, select Requirements Traceability > Enable Traceability
Highlighting.

Disable Traceability Highlighting of MATLAB Code

To turn off highlighting of traceability links in your MATLAB code, do one of the
following:

• In the View tab, in the Display section, clear Highlight Traceability.
• In the MATLAB Editor, right-click in a line of code with a traceability link. From the

context menu, select Requirements Traceability > Disable Traceability
Highlighting.
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Remove Traceability Links from MATLAB Code Lines
In this section...
“Delete Links to Requirements from MATLAB Code Lines” on page 5-171
“Delete Link Targets in MATLAB Code Lines” on page 5-171

Delete Links to Requirements from MATLAB Code Lines

To remove requirements traceability links from a line or lines of MATLAB code:

1 In the MATLAB Editor, right-click within a range of code that has requirements
traceability links.

2 From the context menu, select Requirements Traceability > Delete All Links.

All links to requirements from this MATLAB code range are deleted. Links to this
MATLAB code range from external requirements documents are not deleted.

Delete Link Targets in MATLAB Code Lines

If you have links to MATLAB code ranges from external requirements documents, you
can delete the targets for these links from your MATLAB code.

To remove requirements traceability targets from a line or lines of MATLAB code, after
you have deleted its outgoing links as described in the previous section:

1 In the MATLAB Editor, right-click within a previously linked range of code.
2 From the context menu, select Requirements Traceability > Discard Named

Range.

When you discard a named range, links to that MATLAB code range from external
documents no longer work. Note, however, that this does not delete navigation
objects in external requirements documents.
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Traceability for MATLAB Code Lines

In this section...
“Traceability Link Targets” on page 5-172
“Storage of Traceability Links” on page 5-172
“Limitations of MATLAB Code Traceability” on page 5-173

Traceability Link Targets

You can create MATLAB code traceability links for:

• Lines of MATLAB code in a standalone file.
• Lines of MATLAB code inside a MATLAB Function block.

You can create links from a line or lines of MATLAB code to:

• Objects in Simulink models.
• Targets in Microsoft Word or Microsoft Excel documents.
• Targets in IBM Rational DOORS databases.
• Targets in text, HTML, or PDF documents.
• HTTP URLs.

Bidirectional linking is supported for targets in MATLAB, Simulink, Microsoft Word,
Microsoft Excel, and IBM Rational DOORS. Bidirectional linking creates links to and
from the selected link destination. To enable bidirectional linking, in the Requirements
Settings dialog box, under the Selection Linking tab, select Modify destination for
bidirectional linking. For more information, see “Selection Linking Tab” on page 5-23.

You can also create links to MATLAB code lines from any external application that
supports HTTP navigation. For more information, see “Link from External Applications”
on page 5-27.

Storage of Traceability Links

In a standalone MATLAB file, you can create, navigate, and delete traceability links for
lines of code without changing the MATLAB file. The Requirements Management
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Interface stores requirements traceability data for a MATLAB file in a .req file with the
same name and location as the MATLAB file.

If you want to create traceability links for lines of code in a MATLAB Function block, set
the parent model to store requirements data externally. For a new model, see “Specify
Storage for Requirements Links” on page 5-63. For an existing model, see “Move
Internally Stored Requirements Links to External Storage” on page 5-66. When you
create traceability links for code inside a MATLAB Function block, the RMI stores them
in a .req file for the parent model. The .req file for the model contains requirements
traceability data for linked model objects and for linked code in MATLAB Function
blocks in the model.

Limitations of MATLAB Code Traceability

Overlapping Linked Ranges

The software does not support traceability links for overlapping regions of MATLAB
code. If one linked range of code completely overlaps another smaller region of code, the
link for the larger range overshadows the link for the smaller range. To avoid
complications from overlapping linked ranges, when you create traceability links for
MATLAB code lines, choose ranges of code that do not overlap.

Cut and Paste Operations

You can cut or copy a selection of code that has traceability links. When you paste that
selection, the software attempts to recreate the corresponding traceability links at the
paste location. Depending on paste location and code formatting, you might need to
recreate the traceability links manually.

Drag Operation

If you select code that has traceability links and drag that code to a new location, you
might need to recreate traceability links for the code in the new location.

MATLAB Function Block Code Traceability in Web View

Requirements linked to individual MATLAB code lines inside a MATLAB Function block
appear in HTML requirements traceability reports, but do not appear the Simulink
Report Generator Web view. See “Create and Use a Web View” (Simulink Report
Generator).
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Traceability for MATLAB Live Editor

Requirements traceability is not supported for MATLAB Live Editor.
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Why Create a Custom Link Type?
In addition to linking to built-in types of requirements documents, you can register
custom requirements document types with the Requirements Management Interface
(RMI). Then you can create requirement links from your model to these types of
documents.

With custom link types, you can:

• Link to requirement items in commercial requirement tracking software
• Link to in-house database systems
• Link to document types that the RMI does not support

The custom link type API allows you to define MATLAB functions that enable linking
between your Simulink model and your custom requirements document type. These
functions also enable new link creation and navigation between the model and
documents.

For example, navigation involves opening a requirements document and finding the
specific requirement record. When you click your custom link in the content menu of a
linked object in the model, Simulink uses your custom link type navigation function to
open the document and highlight the target requirement based on the implementation
provided. The navigation function you implement uses the available API to communicate
with your requirements storage application.

Typically, MATLAB runs an operating system shell command or uses ActiveX
communication for sending navigation requests to external applications.

Alternatively, if your requirements are stored as custom variants of text or HTML files,
you can use the built-in editor or Web browser to open the requirements document.
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Implement Custom Link Types
To implement a custom link type:

1 Create a MATLAB function file based on the custom link type template, as described
in “Custom Link Type Functions” on page 5-177.

2 Customize the custom link type file to specify the link type properties and custom
callback functions required for the custom link type, as described in “Link Type
Properties” on page 5-179.

3 Register the custom link type using the rmi command 'register' option, as
described in “Custom Link Type Registration” on page 5-183.
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Custom Link Type Functions
To create a MATLAB function file, start with the custom link type template, located in:

matlabroot\toolbox\slrequirements\linktype_examples\linktype_TEMPLATE.m

Your custom link type function:

• Must exist on the MATLAB path with a unique function and file name.
• Cannot require input arguments.
• Must return a single output argument that is an instance of the requirements link

type class.

To view similar files for the built-in link types, see the following files in matlabroot
\toolbox\slrequirements\linktype_examples\:

linktype_rmi_doors.m
linktype_rmi_excel.m
linktype_rmi_html.m
linktype_rmi_text.m
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Links and Link Types
Requirements links are the data structures, managed by Simulink, that identify a
specific location within a document. You get and set the links on a block using the rmi
command.

Links and link types work together to perform navigation and manage requirements. The
doc and id fields of a link uniquely identify the linked item in the external document.
The RMI passes both of these values to the navigation command when you navigate a
link from the model.
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Link Type Properties
Link type properties define how links are created, identified, navigated to, and stored
within the requirement management tool. The following table describes each of these
properties.
Property Description
Registration The name of the function that creates the link type. The RMI

stores this name in the Simulink model.
Label A string to identify this link type. In the “Requirements

Traceability Link Editor” on page 5-20, this string appears on
the Document type drop-down list for a Simulink or
Stateflow object.

IsFile A Boolean property that indicates if the linked documents are
files within the computer file system. If a document is a file:

• The software uses the standard method for resolving the
path.

• In the Requirements Traceability Link Editor, when you
click Browse, the file selection dialog box opens.

Extensions An array of file extensions. Use these file extensions as filter
options in the Requirements Traceability Link Editor when
you click Browse. The file extensions infer the link type based
on the document name. If you registered more than one link
type for the same file extension, the link type that you
registered takes first priority.

LocDelimiters A string containing the list of supported navigation delimiters.
The first character in the ID of a requirement specifies the type
of identifier. For example, an identifier can refer to a specific
page number (#4), a named bookmark (@my_tag), or some
searchable text (?search_text). The valid location delimiters
determine the possible entries in the Requirements
Traceability Link Editor Location drop-down list.

NavigateFcn The MATLAB callback invoked when you click a link. The
function has two input arguments: the document field and the
ID field of the link:
feval(LinkType.NavigateFcn, Link.document, Link.id)
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Property Description
ContentsFcn The MATLAB callback invoked when you click the Document

Index tab in the Requirements Traceability Link Editor. This
function has a single input argument that contains the full
path of the resolved function or, if the link type is not a file, the
Document field contents.

The function returns three outputs:

• Labels
• Depths
• Locations

BrowseFcn The MATLAB callback invoked when you click Browse in the
Requirements Traceability Link Editor. You do not need this
function when the link type is a file. The function takes no
input arguments and returns a single output argument that
identifies the selected document.

CreateURLFcn The MATLAB callback that constructs a path name to the
requirement. This function uses the document path or URL to
create a specific requirement URL. The requirement URL is
based on a location identifier specified in the third input
argument. The input arguments are:

• Full path name to the requirements document
• Info about creating a URL to the document (if applicable)
• Location of the requirement in the document

This function returns a single output argument specified as a
character vector. Use this argument when navigating to the
requirement from the generated report.

IsValidDocFcn The MATLAB callback invoked when you run a requirements
consistency check. The function takes one input argument—the
fully qualified name for the requirements document. It returns
true if the document can be located; it returns false if the
document cannot be found or the document name is invalid.
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Property Description
IsValidIdFcn The MATLAB callback invoked when you run a requirements

consistency check. This function takes two input arguments:

• Fully qualified name for the requirements document
• Location of the requirement in the document

IsValidIdFcn returns true if it finds the requirement and
false if it cannot find that requirement in the specified
document.

IsValidDescFcn The MATLAB callback invoked when you run a requirements
consistency check. This function has three input arguments:

• Full path to the requirements document
• Location of the requirement in the document
• Requirement description label as stored in Simulink

IsValidDescFcn returns two outputs:

• True if the description matches the requirement, false
otherwise.

• The requirement label in the document, if not matched in
Simulink.
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Property Description
DetailsFcn The MATLAB callback invoked when you generate the

requirements report with the Include details from linked
documents option. This function returns detailed content
associated with the requirement and has three input
arguments:

• Full path to the requirements document
• Location of the requirement in the document
• Level of details to include in report (Unused)

The DetailsFcn returns two outputs:

• Numeric array that describes the hierarchical relationship
among the fragments in the cell array

• Cell array of formatted fragments (paragraphs, tables, et
al.) from the requirement

SelectionLinkFcn The MATLAB callback invoked when you use the selection-
based linking menu option for this document type. This
function has two input arguments:

• Handle to the model object that will have the requirement
link

• True if a navigation object is inserted into the requirements
document, or false if no navigation object is inserted

SelectionLinkFcn returns the requirements link structure
for the selected requirement.
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Custom Link Type Registration
Register your custom link type by passing the name of the MATLAB function file to the
rmi command as follows:

rmi register mytargetfilename

Once you register a link type, it appears in the “Requirements Traceability Link Editor”
on page 5-20 as an entry in the Document type drop-down list. A file in your preference
folder contains the list of registered link types, so the custom link type is loaded each
time you run MATLAB.

When you create links using custom link types, the software saves the registration name
and the other link properties specified in the function file. When you attempt to navigate
to such a link, the RMI resolves the link type against the registered list. If the software
cannot find the link type, you see an error message.

You can remove a link type with the following MATLAB command:

rmi unregister mytargetfilename
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Create a Custom Requirements Link Type
In this example, you implement a custom link type to a hypothetical document type, a
text file with the extension .abc. Within this document, the requirement items are
identified with a special text string, Requirement::, followed by a single space and then
the requirement item inside quotation marks (").

You will create a document index listing all the requirement items. When navigating
from the Simulink model to the requirements document, the document opens in the
MATLAB Editor at the line of the requirement that you want.

To create a custom link requirement type:

1 Write a function that implements the custom link type and save it on the MATLAB
path.

For this example, the file is rmicustabcinterface.m, containing the function,
rmicustabcinterface, that implements the ABC files shipping with your
installation.

2 To view this function, at the MATLAB prompt, type:

edit rmicustabcinterface

The file rmicustabcinterface.m opens in the MATLAB Editor. The content of the
file is:
function linkType = rmicustabcinterface
%RMICUSTABCINTERFACE - Example custom requirement link type
%
% This file implements a requirements link type that maps 
% to "ABC" files.
% You can use this link type to map a line or item within an ABC
% file to a Simulink or Stateflow object.
%
% You must register a custom requirement link type before using it.
% Once registered, the link type will be reloaded in subsequent
% sessions until you unregister it.  The following commands
% perform registration and registration removal.
%
% Register command:   >> rmi register rmicustabcinterface
% Unregister command: >> rmi unregister rmicustabcinterface
%
% There is an example document of this link type contained in the
% requirement demo directory to determine the path to the document
% invoke:
%
% >> which demo_req_1.abc

%  Copyright 1984-2010 The MathWorks, Inc.
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    % Create a default (blank) requirement link type
    linkType = ReqMgr.LinkType;
    linkType.Registration = mfilename;

    % Label describing this link type
    linkType.Label = 'ABC  file (for demonstration)';

    % File information
    linkType.IsFile = 1;
    linkType.Extensions = {'.abc'};

    % Location delimiters
    linkType.LocDelimiters = '>@';
    linkType.Version = '';             % not required

    % Uncomment the functions that are implemented below
    linkType.NavigateFcn = @NavigateFcn;
    linkType.ContentsFcn = @ContentsFcn;

function NavigateFcn(filename,locationStr)
    if ~isempty(locationStr)
        findId=0;
        switch(locationStr(1))
        case '>'
            lineNum = str2num(locationStr(2:end));
            openFileToLine(filename, lineNum);
        case '@'
            openFileToItem(filename,locationStr(2:end));
        otherwise
            openFileToLine(filename, 1);
        end
    end

function openFileToLine(fileName, lineNum)
    if lineNum > 0        
        if matlab.desktop.editor.isEditorAvailable
            matlab.desktop.editor.openAndGoToLine(fileName, lineNum);
        end
    else
        edit(fileName);
    end

function openFileToItem(fileName, itemName)
    reqStr = ['Requirement:: "' itemName '"'];
    lineNum = 0;
    fid = fopen(fileName);
    i   = 1;
    while lineNum == 0
        lineStr = fgetl(fid);
        if ~isempty(strfind(lineStr, reqStr))
            lineNum = i;
        end;
        if ~ischar(lineStr), break, end;
        i = i + 1;
    end;
    fclose(fid);
    openFileToLine(fileName, lineNum);
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function [labels, depths, locations] = ContentsFcn(filePath)
    % Read the entire file into a variable
    fid = fopen(filePath,'r');
    contents = char(fread(fid)');
    fclose(fid);

    % Find all the requirement items
    fList1 = regexpi(contents,'\nRequirement:: "(.*?)"','tokens');

    % Combine and sort the list
    items = [fList1{:}]';
    items = sort(items);
    items = strcat('@',items);

    if (~iscell(items) && length(items)>0)
     locations = {items};
     labels = {items};
    else
     locations = [items];
     labels = [items];
    end

    depths = [];

3 To register the custom link type ABC, type the following MATLAB command:

rmi register rmicustabcinterface

The ABC file type appears on the “Requirements Traceability Link Editor” on page
5-20 drop-down list of document types.

4 Create a text file with the .abc extension containing several requirement items
marked by the Requirement:: string.

For your convenience, an example file ships with your installation. The example file
is matlabroot\toolbox\slvnv\rmidemos\demo_req_1.abc. demo_req_1.abc
contains the following content:

Requirement:: "Altitude Climb Control"

Altitude climb control is entered whenever:
|Actual Altitude- Desired Altitude | > 1500 

Units:
Actual Altitude - feet
Desired Altitude - feet

Description:

When the autopilot is in altitude climb 
control mode, the controller maintains a 
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constant user-selectable target climb rate.  

The user-selectable climb rate is always a 
positive number if the current altitude is 
above the target altitude.  The actual target 
climb rate is the negative of the user 
setting. 

End of "Altitude Climb Control">

Requirement:: "Altitude Hold"

Altitude hold mode is entered whenever:
|Actual Altitude- Desired Altitude | < 
  30*Sample Period*(Pilot Climb Rate / 60) 

Units:
Actual Altitude - feet
Desired Altitude - feet
Sample Period - seconds
Pilot Climb Rate - feet/minute

Description:

The transition from climb mode to altitude 
hold is based on a threshold that is 
proportional to the Pilot Climb Rate.  

At higher climb rates the transition occurs 
sooner to prevent excessive overshoot. 

End of "Altitude Hold"

Requirement:: "Autopilot Disable"

Altitude hold control and altitude climb 
control are disabled when autopilot enable 
is false.

Description:

Both control modes of the autopilot 
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can be disabled with a pilot setting.

ENd of "Autopilot Disable"

Requirement:: "Glide Slope Armed"

Glide Slope Control is armed when Glide 
Slope Enable and Glide Slope Signal 
are both true. 

Units:
Glide Slope Enable - Logical
Glide Slope Signal - Logical

Description:

ILS Glide Slope Control of altitude is only 
enabled when the pilot has enabled this mode 
and the Glide Slope Signal is true.  This indicates 
the Glide Slope broadcast signal has been 
validated by the on board receiver. 

End of "Glide Slope Armed"

Requirement:: "Glide Slope Coupled"

Glide Slope control becomes coupled when the control 
is armed and (Glide Slope Angle Error > 0) and 
 Distance < 10000 

Units:
Glide Slope Angle Error - Logical
Distance - feet

Description:

When the autopilot is in altitude climb control 
mode the controller maintains a constant user 
selectable target climb rate.  

The user-selectable climb rate is always a positive 
number if the current altitude is above the target 
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altitude the actual target climb rate is the 
negative of the user setting. 

End of "Glide Slope Coupled"
5 Open the following example model:

aero_dap3dof
6 Right-click the Reaction Jet Control subsystem and select Requirements

Traceability > Open Link Editor.

The Requirements Traceability Link Editor opens.
7 Click New to add a new requirement link. The Document type drop-down list now

contains the ABC file (for demonstration) option.

8 Set Document type to ABC file (for demonstration) and browse to the
matlabroot\toolbox\slvnv\rmidemos\demo_req_1.abc file. The browser
shows only the files with the .abc extension.

9 To define a particular location in the requirements document, use the Location
field.

In this example, the rmicustabcinterface function specifies two types of location
delimiters for your requirements:

• > — Line number in a file
• @ — Named item, such as a bookmark, function, or HTML anchor
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Note The rmi reference page describes other types of requirements location
delimiters.

The Location drop-down list contains these two types of location delimiters
whenever you set Document type to ABC file (for demonstration).

10 Select Line number. Enter the number 26, which corresponds with the line number
for the Altitude Hold requirement in demo_req_1.abc.

11 In the Description field, enter Altitude Hold, to identify the requirement by
name.

12 Click Apply.
13 Verify that the Altitude Hold requirement links to the Reaction Jet Control

subsystem. Right-click the subsystem and select Requirements Traceability > 1.
“Altitude Hold”.

Create a Document Index

A document index is a list of all the requirements in a given document. To create a
document index, MATLAB uses file I/O functions to read the contents of a requirements
document into a MATLAB variable. The RMI extracts the list of requirement items.

The example requirements document, demo_req_1.abc, defines four requirements
using the string Requirement::. To generate the document index for this ABC file, the
ContentsFcn function in rmicustabcinterface.m extracts the requirements names
and inserts @ before each name.

For the demo_req_1.abc file, in the Link Editor: Reaction Jet Control dialog box,
click the Document Index tab. The ContentsFcn function generates the document
index automatically.
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Custom Link Type Synchronization
After you implement custom link types for RMI that allow you to establish links from
Simulink objects to requirements in your requirements management application (RM
application), you can implement synchronization of the links between the RM application
and Simulink Requirements functions. Links can then be reviewed and managed in your
RM application environment, while changes made are propagated to Simulink.

You first create the surrogate objects in the RM application to represent Simulink objects
of interest. You then automate the process of establishing traceability links between
these surrogate objects and other items stored in the RM application, to match links that
exist on the Simulink side. After modifying or creating new associations in the RM
application, you can propagate the changes back to Simulink. You use Simulink
Requirements to implement synchronization of links for custom requirements
documents. However, this functionality is dependent upon the automation and inter-
process communication APIs available in your RM application. You use the following
Simulink Requirements functions to implement synchronization of links between RM
applications and Simulink.

To get a complete list of Simulink objects that may be considered for inclusion in the
surrogate module:
[objHs, parentIdx, isSf, objSIDs] = slrequirements...
('getObjectsInModel', modelName);

This command returns:

• objHs, a complete list of numeric handles
• objSIDs, a complete list of corresponding session-independent Simulink IDs
• isSf, a logical array that indicates which list positions correspond to which Stateflow

objects
• parentIdx, an array of indices that provides model hierarchy information

When creating surrogate objects in your RM application, you will need to store objSIDs
values – not objHs values – because objHs values are not persistent between Simulink
sessions.

To get Simulink object Name and Type information that you store on the RM application
side:
[objName, objType] = slrequirements('getObjLabel', slObjectHandle);

5 Requirements Management Interface

5-192



To query links for a Simulink object, specified by either numeric handle or SID:

linkInfo = slrequirements('getLinks', slObjectHandle)
linkInfo = slrequirements('getLinks', sigBuildertHandle, m)
% Signal Builder group "m" use case.
linkInfo = slrequirements('getLinks', [modelName objSIDs{i}]);

linkInfo is a MATLAB structure that contains link attributes. See the rmi function
reference page for more details.

After you retrieve the updated link information from your RM application, populate the
fields of linkData with the updated values, and propagate the changes to Simulink:

slrequirements('setLinks', slObjectHandle, linkData)

For an example MATLAB script implementing synchronization with a Microsoft Excel
Workbook, see the following:

edit([matlabroot '/toolbox/slrequirements/...
linktype_examples/slSurrogateInExcel.m'])

You can run this MATLAB script on the example model
slvnvdemo_fuelsys_officereq to generate the Excel workbook surrogate for the
model.
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Navigate to Simulink Objects from External Documents
The RMI includes several functions that simplify creating navigation interfaces in
external documents. The external application that displays your document must support
an application programming interface (API) for communicating with the MATLAB
software.

Provide Unique Object Identifiers

Whenever you create a requirement link for a Simulink or Stateflow object, the RMI uses
a globally unique identifier for that object. This identifier identified the object. The
identifier does not change if you rename or move the object, or add or delete requirement
links. The RMI uses the unique identifier only to resolve an object within a model.

Use the rmiobjnavigate Function

The rmiobjnavigate function identifies the Simulink or Stateflow object, highlights
that object, and brings the editor window to the front of the screen. When you navigate to
a Simulink model from an external application, invoke this function.

The first time you navigate to an item in a particular model, you might experience a
slight delay while the software initializes the communication API and the internal data
structures. You do not experience a long delay on subsequent navigation.

Determine the Navigation Command

To create a requirement link for a Simulink or Stateflow object, at the MATLAB prompt,
use the following command to find the navigation command, where obj is a handle or a
uniquely resolved name for the object:

[ navCmd, objPath ] = rmi('navCmd', obj);

The return values of the navCmd method are:

• navCmd — A character vector that navigates to the object when evaluated by the
MATLAB software.

• objPath — A character vector that identifies the model object.
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Send navCmd to the MATLAB software for evaluation when navigating from the external
application to the object obj in the Simulink model. Use objPath to visually identify the
target object in the requirements document.

Use the ActiveX Navigation Control

The RMI uses software that includes a special Microsoft ActiveX control to enable
navigation to Simulink objects from Microsoft Word and Excel documents. You can use
this same control in any other application that supports ActiveX within its documents.

The control is derived from a push button and has the Simulink icon. There are two
instance properties that define how the control works. The tooltipstring property is
displayed in the control tooltip. The MLEvalCmd property is the character vector that you
pass to the MATLAB software for evaluation when you click the control.

Typical Code Sequence for Establishing Navigation Controls

When you create an interface to an external tool, you can automate the procedure for
establishing links. This way, you do not need to manually update the dialog box fields.
This type of automation occurs as part of the selection-based linking for certain built-in
types, such as Microsoft Word and Excel documents.

To automate the procedure for establishing links:

1 Select a Simulink or Stateflow object and an item in the external document.
2 Invoke the link creation action either from a Simulink menu or command, or a

similar mechanism in the external application.
3 Identify the document and current item using the scripting capability of the external

tool. Pass this information to the MATLAB software. Create a requirement link on
the selected object using the RMI API as follows:

a Create an empty link structure using the following command:

rmi('createempty')
b Fill in the link structure fields based on the target location in the requirements

document.
c Attach the link to the object using the following command:

rmi('cat')
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4 Determine the MATLAB navigation command that you must embed in the external
tool, using the navCmd method:

[ navCmd, objPath ] = rmi('navCmd',obj)
5 Create a navigation item in the external document using the scripting capability of

the external tool. Set the MATLAB navigation command in the property.

When using ActiveX navigation objects provided by the external tool, set the
MLEvalCmd property to the navCmd and set the tooltipstring property to
objPath.

You define the MATLAB code implementation of this procedure as the
SelectionLinkFcn function in the link type definition file. The following files in
matlabroot\toolbox\shared\reqmgt\+linktypes contain examples of how to
implement this functionality:

linktype_rmi_doors.m
linktype_rmi_excel.m
linktype_rmi_html.m
linktype_rmi_text.m
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How Requirements Information Is Included in Generated Code
After you simulate your model and verify its performance against the requirements, you
can generate code from the model for an embedded real-time application. The Embedded
Coder software generates code for Embedded Real-Time (ERT) targets.

If the model has any links to requirements, the Embedded Coder software inserts
information about the requirements links into the code comments.

For example, if a block has a requirement link, the software generates code for that
block. In the code comments for that block, the software inserts:

• Requirement description
• Hyperlink to the requirements document that contains the linked requirement

associated with that block

Note

• You must have a license for Embedded Coder to generate code for an embedded real-
time application.

• If you use an external .req file to store your requirement links, to avoid stale
comments in generated code, before code generation, you must save any change in
your requirement links. For information on how to save, see “Save Requirements
Links in External Storage” on page 5-64.

Comments for the generated code include requirements descriptions and hyperlinks to
the requirements documents in the following locations.
Model Object with Requirement Location of Code Comments with

Requirements Links
Model In the main header file, <model>.h
Nonvirtual subsystem At the call site for the subsystem
Virtual subsystem At the call site of the closest nonvirtual

parent subsystem. If a virtual subsystem
does not have a nonvirtual parent,
requirement descriptions appear in the
main header file for the model, <model>.h.
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Model Object with Requirement Location of Code Comments with
Requirements Links

Nonsubsystem block In the generated code for the block
MATLAB code line in MATLAB Function
block

In the generated code for the MATLAB
code line(s)
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Generate Code for Models with Requirements Links
To specify that generated code of an ERT target include requirements:

1 Open the rtwdemo_requirements example model.
2 Select Simulation > Model Configuration Parameters.
3 In the Select tree of the Configuration Parameters dialog box, select the Code

Generation node.

The currently configured system target must be an ERT target.

4 Under Code Generation, select Comments.
5 In the Custom comments section on the right, select the Requirements in block

comments check box.
6 Under Code Generation, select Report.
7 On the Report pane, select:

• Create code generation report
• Open report automatically

8 Press Ctrl+B to build the model.
9 In the code-generation report, open rtwdemo_requirements.c.
10 Scroll to the code for the Pulse Generator block, clock. The comments for the code

associated with that block include a hyperlink to the requirement linked to that
block.
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11 Click the link Clock period shall be consistent with chirp tolerance
to open the HTML requirements document to the associated requirement.

Note When you click a requirements link in the code comments, the software opens
the application for the requirements document, except if the requirements document
is a DOORS module. To view a DOORS requirement, start the DOORS software and
log in before clicking the hyperlink in the code comments.
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Verification and Validation

• “Test Model Against Requirements and Report Results” on page 6-2
• “Analyze a Model for Standards Compliance and Design Errors” on page 6-6
• “Perform Functional Testing and Analyze Test Coverage” on page 6-9
• “Analyze Code and Test Software-in-the-Loop” on page 6-13
• “Module Verification and Testing Processor-in-the-Loop” on page 6-22
• “Test a Model in Real Time” on page 6-23
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Test Model Against Requirements and Report Results

Requirements Overview
Requirements are the basis for your system architecture, algorithm, and test plan.
Traceability between requirements documents, model, code, and tests helps you
document relationships, manage design changes, and interpret test results. Required
model properties and test objectives enable targeted design analysis and test case
generation for specific scenarios. You can evaluate your design and identify incomplete or
missing requirements with ad-hoc testing, using simulated user interfaces for your
model. Also, you can use rapid prototyping to validate requirements, and connect to
physical or simulated environments to test your algorithm. Update the design, adding
requirements and requirements links as necessary.

Test a Cruise Control Safety Requirement
This example shows a requirements-based testing workflow for a cruise control model.
You start with a model that has traceability to an external requirements document. You
add a test to evaluate two safety requirements, checking that the cruise control
disengages when the system reaches certain conditions. You add traceability to this test,
run the test, and report the results.

1 Create a copy of the project in a working folder. Enter

slVerificationCruiseStart
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2 Open the model and the test harness. On the command line, enter

open_system simulinkCruiseAddReqExample
sltest.harness.open('simulinkCruiseAddReqExample','SafetyTest_Harness1')

3 Open the Test Sequence block.

• The BrakeTest sequence tests that the system disengages when the brake pedal
is pressed. It includes a verify statement

verify(engaged == false,...
    'verify:brake',...
    'system must disengage when brake applied')

• The LimitTest sequence tests that the system disengages when the speed
exceeds a limit. It includes a verify statement

verify(engaged == false,...
    'verify:limit',...
    'system must disengage when limit exceeded')

4 Open the requirements document. In the Simulink Project window, expand the
documents folder and open simulinkCruiseChartReqs.docx.

5 Add links between the test steps and the requirements document.

1 In the requirements document, highlight item 3.1, “Vehicle braking will
transition system to disengaged (inactive) when engaged (active)”

2 With item 3.1 highlighted, in the test sequence, right-click the BrakeTest step.
Select Requirements traceability > Link to Selection in Word.

3 In the requirements document, highlight item 3.4, “Transition to disengaged
(inactive) when vehicle speed is outside the limits of 20 mph to 90 mph”

4 With item 3.4 highlighted, in the test sequence, right-click the LimitTest step.
Select Requirements traceability > Link to Selection in Word.

5 Save the requirements document and the model.
6 Create a test case in the Test Manager, and link the test case to the requirements

section.

1 Open the Test Manager. In the Simulink menu, select Analysis > Test
Manager.

2 In the Test Manager toolstrip, click New > Test File. Select the tests folder in
the project, and enter a name for the test file. Click Save.

A new baseline test is created.
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3 Under System Under Test, in the Model field, click the button  to use the
current model. The field displays the model name.

4 Expand the Test Harness section. From the drop-down menu, select the test
harness name.

5 In the requirements document, highlight section 3.1.
6 In the test case, expand the Requirements section. Click the arrow next to the

Add button and select Link to Selection in Word.
7 Use the same process to link the test case to section 3.4 in the requirements

document.
7 Highlight the test case. In the Test Manager toolstrip, click Run.
8 When the test finishes, expand the Verify Statements results. The results show

that both assessments pass, and the plot shows the detailed results of each
statement.

9 Create a report using a custom Microsoft Word template.

1 In the Test Manager, right-click the test case name. Select Results: > Create
Report.

2 In the Create Test Result Report dialog box, set the options:

• Title: SafetyTest
• Results for: All Tests
• File Format: DOCX
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• For the other options, keep the default selections.
3 For the Template File, select the ReportTemplate.dotx file in the

documents project folder.
4 Enter a file name and select a location for the report.
5 Click Create.

10 Review the report.

1 In the Test Case Requirements section, click the link to trace to the
requirements document.

2 The Verify Result section contains details of the two assessments in the test,
and links to the simulation output.

See Also

Related Examples
• “Link Tests to Requirements” (Simulink Test)
• “Validate Requirements Links in a Model” on page 5-102
• “Customize Requirements Traceability Report for Model” on page 5-73
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Analyze a Model for Standards Compliance and Design Errors

Standards and Analysis Overview

During model development, check and analyze your model to increase confidence in its
quality. Check your model against standards such as MAAB style guidelines and high-
integrity system design guidelines such as DO-178 and ISO 26262. Analyze your model
for errors, dead logic, and conditions that violate required properties. Using the analysis
results, update your model and document exceptions. Report the results using
customizable templates.

Check Model for Style Guideline Violations and Design Errors

This example shows how to use the Model Advisor to check a cruise control model for
MathWorks® Automotive Advisory Board (MAAB) style guideline violations and design
errors. Select checks and run the analysis on the model. Iteratively debug issues using
the Model Advisor and rerun checks to verify that it is in compliance. After passing your
selected checks, report results.

Check Model for MAAB Style Guideline Violations

In Model Advisor, you can check that your model complies with MAAB modeling
guidelines.
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1 Create a copy of the project in a working folder. On the command line, enter

slVerificationCruiseStart
2 Open the model. On the command line, enter

open_system simulinkCruiseErrorAndStandardsExample
3 In the model window, select Analysis > Model Advisor > Model Advisor.
4 Click OK to choose simulinkCruiseErrorAndStandardsExample from the

System Hierarchy.
5 Check your model for MAAB style guideline violations using Simulink Check.

a In the left pane, in the By Product > Simulink Check > Modeling
Standards > MathWorks Automotive Advisory Board Checks folder,
select:

• Check for indexing in blocks
• Check for prohibited blocks in discrete controllers
• Check model diagnostic parameters

b Right-click the MathWorks Automotive Advisory Board Checks node, and
then select Run Selected Checks.

c Click Check model diagnostic parameters to review the configuration
parameter settings that violate MAAB style guidelines.

d In the right pane, click the parameter links to update the values in the
Configuration Parameters dialog box.

e To verify that your model passes, rerun the check. Repeat steps c and d, if
necessary, to reach compliance.

f To generate a results report of the Simulink Check checks, select the
MathWorks Automotive Advisory Board Checks node, and then, in the
right pane click Generate Report....

Check Model for Design Errors

While in Model Advisor, you can also check your model for hidden design errors using
Simulink Design Verifier.

1 In the left pane, in the By Product > Simulink Design Verifier folder, select
Design Error Detection.
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2 In the right pane, click Run Selected Checks.
3 After the analysis is complete, expand the Design Error Detection folder, then

select checks to review warnings or errors.
4 In the right pane, click Simulink Design Verifier Results Summary. The dialog

box provides tools to help you diagnose errors and warnings in your model.

a Review the results on the model. Click Highlight analysis results on model.
Click the Compute target speed subsystem, outlined in red. The Simulink
Design Verifier Results Inspector window provides derived ranges that can help
you understand the source of an error by identifying the possible signal values.

b Review the harness model. The Simulink Design Verifier Results Inspector
window displays information that an overflow error occurred. To see the test
cases that demonstrate the errors, click View test case.

c Review the analysis report. In the Simulink Design Verifier Results Inspector
window, click Back to summary. To see a detailed analysis report, click HTML
or PDF.

See Also

Related Examples
• “Check for Compliance Using the Model Advisor and Edit-Time Checking”

(Simulink Check)
• “Collect Model Metrics Using the Model Advisor” (Simulink Check)
• “Run a Design Error Detection Analysis” (Simulink Design Verifier)
• “Prove Properties in a Model” (Simulink Design Verifier)
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Perform Functional Testing and Analyze Test Coverage

Functional Testing and Coverage Analysis Overview

Functional testing starts with building test cases based on requirements. These tests can
cover key aspects of your design and verify that individual model components meet
requirements. Test cases include inputs, expected outputs, and acceptance criteria.

By collecting individual test cases within test suites, you can run functional tests
systematically. To check for regression, add baseline criteria to the test cases and test the
model regularly. Coverage measurement reflects the extent to which these tests have
fully exercised the model. Coverage measurement also helps you to add tests and
requirements to meet coverage targets.

Incrementally Increase Test Coverage Using Test Case Generation

This example shows a functional testing-based testing workflow for a cruise control
model. You start with a model that has tests linked to an external requirements
document, analyze the model for coverage in Simulink Coverage, incrementally increase
coverage with Simulink Design Verifier, and report the results.
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Explore the Test Harness and the Model

1 Create a copy of the project in a working folder. At the command line, enter:

slVerificationCruiseStart
2 Open the model and the test harness. At the command line, enter:

open_system simulinkCruiseAddReqExample
sltest.harness.open('simulinkCruiseAddReqExample','SafetyTest_Harness1')

3 Load the test suite from “Test Model Against Requirements and Report Results”
(Simulink Test). At the command line, enter:

open slReqTests.mldatx
4 Open the test sequence block. The sequence tests:

• That the system disengages when the brake pedal is pressed
• That the system disengages when the speed exceeds a limit

Some test sequence steps are linked to a requirements document
simulinkCruiseChartReqs.docx.

Measure Model Coverage

1 In the test manager, enable coverage collection for the test case.

a Open the test manager. In the Simulink menu, click Analysis > Test Manager.
b In the Test Browser, click the slReqTests test file.
c Expand Coverage Settings.
d Under COVERAGE TO COLLECT, select Record coverage for referenced

models.
e Under COVERAGE METRICS, select Decision, Condition, and MCDC.
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2 Run the test. On the test manager toolstrip, click Run.
3 When the test finishes, in the Test Manager, navigate to the test case. The

aggregated coverage results show that the example model achieves 50% decision
coverage, 41% condition coverage, and 25% MCDC coverage.
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Generate Tests to Increase Model Coverage

1 Use Simulink Design Verifier to generate additional tests to increase model
coverage. Select the test case in the Results and Artifacts and open the aggregated
coverage results section.

2 Select the test results from the previous section and then click Add Tests for
Missing Coverage.

The Add Tests for Missing Coverage options open.
3 Under Harness, choose Create a new harness.
4 Click OK to add tests to the test suite using Simulink Design Verifier.
5 Run the updated test suite. On the test manager toolstrip, click Run. The test

results include coverage for the combined test case inputs, achieving increased model
coverage.

See Also

Related Examples
• “Link Tests to Requirements” (Simulink Test)
• “Assess Simulation Using Logical Statements” (Simulink Test)
• “Test Model Output Against a Baseline” (Simulink Test)
• “Highlight Functional Dependencies” (Simulink Design Verifier)
• “Generate Test Cases for Model Decision Coverage” (Simulink Design Verifier)
• “Extend Model Coverage of a Test Case” (Simulink Test)
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Analyze Code and Test Software-in-the-Loop

Code Analysis and Testing Software-in-the-Loop Overview

Analyze code to detect errors, check standards compliance, and evaluate key metrics such
as length and cyclomatic complexity. Typically for handwritten code, you check for run-
time errors with static code analysis and run test cases that evaluate the code against
requirements and evaluate code coverage. Based on the results, refine the code and add
tests. For generated code, demonstrate that code execution produces equivalent results to
the model by using the same test cases and baseline results. Compare the code coverage
to the model coverage. Based on test results, add tests and modify the model to
regenerate code.

Analyze Code for Defects, Metrics, and MISRA C:2012

This workflow describes how to check if your model produces MISRA® C:2012 compliant
code and how to check your generated code for code metrics, code defects, and MISRA
compliance. To produce more MISRA compliant code from your model, you use the code
generation and model advisors. To check whether the code is MISRA compliant, you use
the Polyspace MISRA C:2012 checker and report generation capabilities. For this
example, you use the model simulinkCruiseErrorAndStandardsExample. To open
the model:

1 Open the Simulink project:

slVerificationCruiseStart
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2 From the Simulink project, open the model
simulinkCruiseErrorAndStandardsExample.

Run Code Generator Checks

Before you generate code from your model, there are steps that you can take to generate
code more compliant with MISRA C and more compatible with Polyspace. This example
shows how to use the Code Generation Advisor to check your model before generating
code.

1 Right-click Compute target speed and select C/C++ > Code Generation Advisor.
2 Select the Code Generation Advisor folder. Add the Polyspace objective. The MISRA

C:2012 guidelines objective is already selected.
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3 Click Run Selected Checks.

The Code Generation Advisor checks whether there are any blocks or configuration
settings that are not recommended for MISRA C:2012 compliance and Polyspace
code analysis. For this mode, the check for incompatible blocks passes, but there are
some configuration settings that are incompatible with MISRA compliance and
Polyspace checking.

4 Click on check that was not passed. Accept the parameter changes by selecting
Modify Parameters.

5 Rerun the check by selecting Run This Check.

For your own model, you might not want to use all the recommended configuration
settings. Using nonrecommended settings can generate less MISRA compliant code.

Run Model Advisor Checks

Before you generate code from your model, there are steps you can take to generate code
more compliant with MISRA C and more compatible with Polyspace. This example shows
you how to use the Model Advisor to check your model further before generating code.
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For more checking before generating code, you can also run the Modeling Guidelines for
MISRA C:2012.

1 At the bottom of the Code Generation Advisor window, select Model Advisor.
2 Under the By Task folder, select the Modeling Guidelines for MISRA C:2012

advisor checks.

3 Click Run Selected Checks and review the results.
4 If any of the tasks fail, make the suggested modifications and rerun the checks until

the MISRA modeling guidelines pass.

For your own model, you might not want to use all the recommendations. Using
nonrecommended settings or blocks can generate less MISRA compliant code.

Generate and Analyze Code

After you have done the model compliance checking, you can now generate code. With
Polyspace, you can check your code for compliance with MISRA C:2012 and generate
reports to demonstrate compliance with MISRA C:2012.
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1 In the Simulink editor, right-click Compute target speed and select C/C++ > Build
This Subsystem.

2 Use the default settings for the tunable parameters and select Build.
3 After the code is generated, right-click Compute target speed and select Polyspace

> Options.

4 Click the Configure (Polyspace Bug Finder) button. This option allows you to
choose more advanced Polyspace analysis options in the Polyspace configuration
window.
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5 On the same pane, select Calculate Code Metrics. This option turns on code
metric calculations for your generated code.

6 Save and close the Polyspace configuration window.
7 From your model, right-click Compute target speed and select Polyspace > Verify

Code Generated For > Selected Subsystem.

Polyspace Bug Finder analyzes the generated code for a subset of MISRA checks and
defect checks. You can see the progress of the analysis in the MATLAB Command
Window. Once the analysis is finished, the Polyspace environment opens.

Review Results

After you run a Polyspace analysis of your generated code, the Polyspace environment
shows you the results of the static code analysis. There are 50 MISRA C:2012 coding rule
violations in your generated code.

6 Verification and Validation
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1 Expand the tree for rule 8.7 and click through the different results.

Rule 8.7 states that functions and objects should not be global if the function or
object is local. As you click through the 8.7 violations, you can see that these results
refer to variables that other components also use, such as CruiseOnOff. You can
annotate your code or your model to justify every result. But, because this model is a
unit in a larger program, you can also change the configuration of the analysis to
check only a subset of MISRA rules.

2 In your model, right-click Compute target speed and select Polyspace > Options.
3 Set the Settings from (Polyspace Bug Finder) option to Project configuration.

This option allow you to choose a subset of MISRA rules in the Polyspace
configuration.

4 Click the Configure button.
5 In the Polyspace Configuration window, on the Coding Rules & Code Metrics

pane, select the check box Check MISRA C:2012 and from the drop-down list, select
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single-unit-rules. Now, Polyspace checks only the MISRA C:2012 rules that are
applicable to a single unit.

6 Save and close the Polyspace configuration window.
7 Rerun the analysis with the new configuration.

When the Polyspace environment reopens, there are no MISRA results, only code
metric results. The rules Polyspace showed previously were found because the model
was analyzed by itself. When you limited the rules Polyspace checked to the single-
unit subset, no violations were found.
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When this model is integrated with its parent model, you can add the rest of the MISRA
C:2012 rules.

Generate Report

To demonstrate compliance with MISRA C:2012 and report on your generated code
metrics, you must export your results. This section shows you how to generate a report
after the analysis. If you want to generate a report every time you run an analysis, see
Generate report.

1 If they are not open already, open your results in the Polyspace environment.
2 From the toolbar, select Reporting > Run Report.
3 Select BugFinderSummary as your report type.
4 Click Run Report.

The report is saved in the same folder as your results.
5 To open the report, select Reporting > Open Report.

See Also

Related Examples
• “Analyze Generated Code Using Polyspace Bug Finder” (Polyspace Bug Finder)
• “Test Two Simulations for Equivalence” (Simulink Test)
• “Export Test Results and Generate Reports” (Simulink Test)
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Module Verification and Testing Processor-in-the-Loop

Module Verification and Testing Processor-in-the-Loop Overview

Module verification involves testing and analyzing code at a system level, integrating
generated code from your model, handwritten code, and legacy code. Module verification
often includes generating code that executes on a target object, rather than the desktop
environment. Analyze the code to resolve errors and evaluate key metrics. Test the
integrated system using new requirements-based tests and system-level tests from your
model. Collect coverage on these tests and add tests to meet coverage targets.

See Also

Related Examples
• “Test Two Simulations for Equivalence” (Simulink Test)
• “Analyze Generated Code Using Polyspace Bug Finder” (Polyspace Bug Finder)
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Test a Model in Real Time

Real-Time Testing and Testing Production Models Overview

Real-time testing assesses the system while including the effects of timers, physical
signals, and target hardware. Sweep through parameter values on the target, verify
system operation during execution, and verify expected results in the desktop
environment. Systems that have been verified on target hardware often exist in a
change-controlled state. You can test these systems without modifying them by using
isolated simulation and analysis environments.

See Also

Related Examples
•
• “Test Models in Real Time” (Simulink Test)
• “Assess Simulation Using Logical Statements” (Simulink Test)

 Test a Model in Real Time

6-23




